Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163458 - A lots of typo/roff mistakes in the man page
Summary: A lots of typo/roff mistakes in the man page
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: logrotate
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-17 12:02 UTC by SEKINE Tatsuo
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-01 12:52:26 UTC


Attachments (Terms of Use)
patch for the man page (deleted)
2005-07-17 12:03 UTC, SEKINE Tatsuo
no flags Details | Diff
new man page (deleted)
2005-07-19 11:51 UTC, Peter Vrabec
no flags Details

Description SEKINE Tatsuo 2005-07-17 12:02:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Please check the patch which I'll put later. Following description is for the patch.

- ".UC" is the macro for the UCB distribution. I think that logrotate was not born in UCB.

- In the configuration file, it is possible to specify multipul files.

- Normally tab stop length is 8 characters, so "+8n" is much better.

- ".pp" is not mandoc(man/mdoc) macro, so I guessed that ".PP" is appropriate.

The others are simple typo/copy&paste mistake.

Version-Release number of selected component (if applicable):
logrotate-3.7.1-10

How reproducible:
Always

Steps to Reproduce:
  

Additional info:

Comment 1 SEKINE Tatsuo 2005-07-17 12:03:15 UTC
Created attachment 116850 [details]
patch for the man page

patch for the man page.

Comment 2 Peter Vrabec 2005-07-19 11:51:43 UTC
Created attachment 116925 [details]
new man page

Are you satisfied with this man page?

Comment 3 SEKINE Tatsuo 2005-07-19 12:48:59 UTC
In this case, I work for JM project, which is the translation project for Japanese.

That project is not Fedora specific, so I cecked out original man page from
rhlinux.redhat.com:/usr/local/CVS. Therefore this (and #163366) report is not
for FC distribution. Because I could not choose appropriate one.

This new man page is including the description of some extra functionalities
which are provided by FC patch. This new one is fine for FC users, but it is not
correct for the original logrotate users.

My suggestion is that "Do as much of the development work as possible directly
in the *upstream* packages.", which is part of Fedora Project's Objectives. If
the all of patches are merged into original repository, more people will be made
happy!


Note You need to log in before you can comment on or make changes to this bug.