Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163455 - Packages dependencies incomplete
Summary: Packages dependencies incomplete
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: cvs
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Ben Levenson
URL:
Whiteboard:
: 163452 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-17 10:05 UTC by Matthieu Pupat
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-22 17:40:18 UTC


Attachments (Terms of Use)

Description Matthieu Pupat 2005-07-17 10:05:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The rpm packages does not depends on compat-libstdc++-296.

Therefore you can uninstall compat-libstdc++-296 from the system without unstalling cvs but then cvs complains:

cvs: error while loading shared libraries: libstdc++-libc6.2-2.so.3: cannot open shared object file: No such file or directory


Version-Release number of selected component (if applicable):
cvs-1.11.19-8

How reproducible:
Always

Steps to Reproduce:
1. Uninstall compat-libstdc++-296
2. Run cvs

Actual Results:  cvs: error while loading shared libraries: libstdc++-libc6.2-2.so.3: cannot open shared object file: No such file or directory


Expected Results:  cvs should run without any error message

Additional info:

Comment 1 Martin Stransky 2005-07-21 10:40:48 UTC
*** Bug 163452 has been marked as a duplicate of this bug. ***

Comment 2 Martin Stransky 2005-07-21 11:06:05 UTC
Are you sure? I tried to remove all _compat_ packages but cvs works properly...

Comment 3 Matthieu Pupat 2005-07-21 17:30:10 UTC
# yum list compat-libstdc++-296
Repository extras already added, not adding again
Setting up repositories
updates-released          100% |=========================|  951 B    00:00
local                     100% |=========================|  951 B    00:00
base                      100% |=========================| 1.1 kB    00:00
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
yum remove Installed Packages
compat-libstdc++-296.i386                2.96-132.fc4           installed



$ cvs update
cvs update: Updating .

# yum remove compat-libstdc++-296
Repository extras already added, not adding again
Setting up Remove Process
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package compat-libstdc++-296.i386 0:2.96-132.fc4 set to be erased
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Removing:
 compat-libstdc++-296    i386       2.96-132.fc4     installed         515 k

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove       1 Package(s)
Total download size: 0
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Removing  : compat-libstdc++-296         ######################### [1/1]

Removed: compat-libstdc++-296.i386 0:2.96-132.fc4
Complete!

$ cvs update
cvs: error while loading shared libraries: libstdc++-libc6.2-2.so.3: cannot open
shared object file: No such file or directory




Comment 4 Martin Stransky 2005-07-22 07:20:28 UTC
$ rpm -qa | grep compat

compat-slang-1.4.5-10
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp_31rh
compat-db-4.2.52-2
compat-readline43-4.3-2
java-1.4.2-gcj-compat-1.4.2.0-40jpp_31rh
java-1.4.2-gcj-compat-src-1.4.2.0-40jpp_31rh
compat-openldap-2.2.23_2.1.30-5
compat-libf2c-32-3.2.3-47.fc4
nss_db-compat-2.2-31

$ cvs update
cvs update: Updating .
cvs update: Updating lesson02a
cvs update: Updating r300_test

Have you installed the original package from fedora repository? Or have you
recompiled it yourself with old gcc?



Comment 5 Matthieu Pupat 2005-07-22 17:40:18 UTC
This was gcvs polluting my PATH


Note You need to log in before you can comment on or make changes to this bug.