Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163453 - "Unknown monitor" causes display to become unreadable.
Summary: "Unknown monitor" causes display to become unreadable.
Keywords:
Status: CLOSED DUPLICATE of bug 163331
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 4
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-17 08:53 UTC by Erik P. Olsen
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-31 18:37:14 UTC


Attachments (Terms of Use)

Description Erik P. Olsen 2005-07-17 08:53:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
The monitor in question is a Samsung SyncMaster model 213T which was recognized by anaconda of FC3 without problems. FC4 doesn't know it.
Graphics card is Matrox G550 correctly identified by anaconda and the monitor is attached to the analogue port.
When it switches to whatever kind of monitor it believes will work the display becomes blurred and is completely unreadable. Booting with linux-lowres doesn't help.

It looks like the ability to handle this monitor has been dropped with FC4.

Is there a way I can run the starter system of FC3 to install FC4?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot DVD with FC4 using default options.
2.
3.
  

Actual Results:  Anaconda comes to the point where it asks you to accept or decline mediacheck and after a short while display becomes blurred as mentioned above.

Expected Results:  Normal installation procedure starting with chosing language etc.

Additional info:

Comment 1 Andre Robatino 2005-07-17 13:42:22 UTC
  The file /usr/share/hwdata/MonitorsDB in the package hwdata-0.158.1-1 for FC4
has the following line:

Samsung; Samsung SyncMaster 213T/CX210T; SAMOO91; 30-81; 56-75; 1

  Hence, if you can install FC4 on this machine using a different monitor,
there's a good chance it will still work when you put the 213T back.

Comment 2 Jeremy Katz 2005-07-18 19:16:19 UTC
Does booting with "linux nofb" help?

Comment 3 Erik P. Olsen 2005-07-18 20:42:03 UTC
No, "linux nofb" doesn't help. Still blurred and unreadable display.

Comment 4 Jeremy Katz 2005-07-26 04:01:46 UTC
Does X work after installation?

Comment 5 Erik P. Olsen 2005-07-26 07:40:28 UTC
Installation is impossible.

Comment 6 Jeremy Katz 2005-07-26 14:48:30 UTC
What if you do a text install?

Comment 7 Erik P. Olsen 2005-07-26 15:09:32 UTC
I have never done that, so I don't know what to do. Can I find a step by step
documentation on the process somewhere?

Comment 8 Dan Carpenter 2005-07-27 05:42:49 UTC
It's basically the same as a graphical install but without using the mouse.

Insert CD #1.
Type "linux text" and press Enter.
Do your normal install but without using a mouse.



Comment 9 Erik P. Olsen 2005-08-01 21:06:50 UTC
OK, did text install yesterday and it went smouth until I was supposed to
reboot, because then the ugly unreadable screen returned. This situation is even
worse because now I have a Fedora Core 4 system that I cannot use.

It looks like the hardware data in /usr/share/hwdata/MonitorsDB is incorrect.

Comment 10 Olivier Baudron 2005-08-11 09:18:58 UTC
I think it's a dup of bug #163331.
Your problem should be fixed in 6.8.2-45. Can you give it a try?

Comment 11 Erik P. Olsen 2005-08-11 11:44:58 UTC
I have tried to install 6.8.2-45 but it's a horrible complicated update with
more than 30 rpms.

Comment 12 Olivier Baudron 2005-08-11 12:29:30 UTC
It may be appropriate to use yum:
yum --enable=development -y update xorg-x11

Comment 13 Olivier Baudron 2005-08-31 18:37:14 UTC

*** This bug has been marked as a duplicate of 163331 ***


Note You need to log in before you can comment on or make changes to this bug.