Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163448 - Kernel panic on SMP boot
Summary: Kernel panic on SMP boot
Keywords:
Status: CLOSED DUPLICATE of bug 163407
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-17 02:49 UTC by Paul Watson
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-28 19:00:43 UTC


Attachments (Terms of Use)
Console serial port log of boot panic (deleted)
2005-07-17 02:49 UTC, Paul Watson
no flags Details

Description Paul Watson 2005-07-17 02:49:57 UTC
+++ This bug was initially created as a clone of Bug #160652 +++

Distribution: fc3
Hardware Environment: Compaq DL580, 4 CPUs
Software Environment:
Problem Description:

Booting 2.6.12-1.1372_FC3smp generates panic.  Console capture in attachment. 
Other kernels, including previous smp, are working. Any suggestions?


title Fedora Core (2.6.12-1.1372_FC3smp)
        root (hd0,0)
        kernel /vmlinuz-2.6.12-1.1372_FC3smp ro root=/dev/VolGroup00/LogVol00
noapic lapic console=tty0 console=ttyS0,9600n8 debug
        initrd /initrd-2.6.12-1.1372_FC3smp.img
title Fedora Core (2.6.12-1.1372_FC3)
        root (hd0,0)
        kernel /vmlinuz-2.6.12-1.1372_FC3 ro root=/dev/VolGroup00/LogVol00
noapic lapic
        initrd /initrd-2.6.12-1.1372_FC3.img
title Fedora Core (2.6.11-1.35_FC3smp)
        root (hd0,0)
        kernel /vmlinuz-2.6.11-1.35_FC3smp ro root=/dev/VolGroup00/LogVol00
noapic lapic
        initrd /initrd-2.6.11-1.35_FC3smp.img


Steps to reproduce: boot smp

Comment 1 Paul Watson 2005-07-17 02:49:57 UTC
Created attachment 116846 [details]
Console serial port log of boot panic

Comment 2 josip 2005-07-20 23:22:37 UTC
kernel-smp-2.6.12-1.1372_FC3 is broken and refuses to boot on two different 
platforms, one with SCSI and one with parallel ATA disks.  Previous kernel-smp-
2.6.11-1.35_FC3 works fine on both platforms.

The failure appears to be related to the new kernel's inability to find root 
partition, specified as either "LABEL=/" or "/dev/hda2".  The old kernel does 
that without any problems.

Comment 3 Dave Jones 2005-07-28 19:00:43 UTC

*** This bug has been marked as a duplicate of 163407 ***


Note You need to log in before you can comment on or make changes to this bug.