Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163446 - System locks when creating a modem device
Summary: System locks when creating a modem device
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-network
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-16 22:15 UTC by Federico Tello Gentile
Modified: 2008-02-18 23:21 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-18 23:21:45 UTC


Attachments (Terms of Use)

Description Federico Tello Gentile 2005-07-16 22:15:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; es-AR; rv:1.7.5) Gecko/20041108 Firefox/1.0

Description of problem:
I order to dial-up to my ISP I have to create a network device to hook it up with the ISP dial info. I am presented a few options: ISDN, Ethernet and Modem. I choose modem and fill in the info (I know the modem is in /dev/ttyS1), when I choose OK, the system locks and stops responding. No action can be done except pressing reset.
The same happens if I open KPPP, it locks before all of its window is finished drawing.
This worked on FC 2 on the same hardware.
If I run setserial -bg /dev/ttyS1 I see the detected modem with its memory address and the IRQ. If I run wvdiaconf it sais the modem was detected on /dev/ttyS1.
I also tried ttyS2 and ttyS3
I have disabled the motheboard's build-im serial port from the BIOS. 

I ran wvdial --chat and after issuing the modem init strings it sais modem is not responding.

The modem appears in the hardare browser as unrecognized device, as it did on FC2.

Version-Release number of selected component (if applicable):
The FC4's original version of system-config-network

How reproducible:
Always

Steps to Reproduce:
1. Try to create the modem device in system-config-network
2. Fill in bauds, /dev/ttyS1
2. Press OK

Actual Results:  I locks. Forces you to press reset since ctr-alt-backspace, numlock or anything else does not work. Mouse stays freezed. No messages in /var/log/messages regarding anything related before the lock-up.

Expected Results:  It should create the modem configuration and alow me to create the ISP configuration.

Additional info:

I know the modem works, since I using it to file the this bug report. I have SELinux enabled. All default services Up, this is a newly installed FC 4. /dev/modem does not exist, but /dev/ttyS[1-3] do exist.
/etc/wvdial.conf seems ok, and issuing command wvdialconf /etc/wvdial.conf reports all succesfull messages telling the modem is there.
The modem is a ISA 3Com U.S.Robotis Voice Faxmodem. V.90. Not a winmodem. I know people are not using these hardware a lot anymore, but this worked fine under FC2 so it is a pity for modem users to have to go back. Besides the lock-up seems strange.

Comment 1 Christian Iseli 2007-01-20 00:39:54 UTC
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.

Comment 2 petrosyan 2008-02-18 23:21:45 UTC
Fedora Core 4 is no longer maintained.

Setting status to "INSUFFICIENT_DATA". If you can reproduce this bug in the
current Fedora release, please reopen this bug and assign it to the
corresponding Fedora version.


Note You need to log in before you can comment on or make changes to this bug.