Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163444 - Text fails to appear when printing
Summary: Text fails to appear when printing
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libgnomeprint
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-16 21:11 UTC by Paul F. Johnson
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-28 21:04:21 UTC


Attachments (Terms of Use)
How printouts appear (deleted)
2005-07-16 21:11 UTC, Paul F. Johnson
no flags Details

Description Paul F. Johnson 2005-07-16 21:11:24 UTC
Description of problem:
Evolution is currently only printing the email bounding box (border) and nothing
else except the page number. I am using a HP Deskjet 980cxi (USB)

Version-Release number of selected component (if applicable):
Evolution-2.2.2-11.fc5
CUPS-1.1.23-16

How reproducible:
Always

Steps to Reproduce:
1. Print an email
2.
3.
  
Actual results:
See attached scan

Expected results:
Email should print

Additional info:

Comment 1 Paul F. Johnson 2005-07-16 21:11:24 UTC
Created attachment 116844 [details]
How printouts appear

Comment 2 Dave Malcolm 2005-07-20 21:58:45 UTC
Thanks for this report.

I'm seeing the same behaviour.  But I think it's a lower level problem; a print
preview from gedit shows similar breakage for me.

What versions of libgnomeprint22/libgnomeprintui22/pango/cairo are you running with?

I'm using the following:
rpm -q libgnomeprint22 libgnomeprintui22 pango cairo
libgnomeprint22-2.10.3-1
libgnomeprintui22-2.10.1-1
pango-1.9.0-1
cairo-0.5.1-3

Are all applications using libgnomeprint affected?  Is gedit affected?



Comment 3 Paul F. Johnson 2005-07-20 22:10:26 UTC
libgnomeprint22-2.11.0-1
libgnomeprintui22-2.11.0-1
pango-1.9.0-1
cairo-0.5.2-1

gedit gives nothing when I print from it, just a line at the bottom of each 
page.

Comment 4 Rodd Clarkson 2005-07-21 01:27:55 UTC
I'm seeing the same thing too.  I'm using:

[rodd@localhost ~]$ rpm -q libgnomeprint22 libgnomeprintui22 pango cairo
libgnomeprint22-2.11.0-1
libgnomeprintui22-2.11.0-1
pango-1.9.0-1
cairo-0.5.2-1

Comment 5 Rodd Clarkson 2005-07-21 01:28:56 UTC
Argh, I should had said, I'm seeing the same thing in both evolution and gedit.

Comment 6 Ryan Skadberg 2005-07-25 15:56:43 UTC
Seeing the same thing here running rawhide.  Happening in both gedit and
evolution.  I even see it in the print previews, not just the physical
printouts.  Here are the versions:

[skadz@codewarrior ~]$ rpm -q libgnomeprint22 libgnomeprintui22 pango cairo
evolution
libgnomeprint22-2.11.0-1
libgnomeprintui22-2.11.0-1
pango-1.9.0-1
cairo-0.5.2-1
evolution-2.2.2-11.fc5


Comment 7 Ryan Skadberg 2005-07-25 16:09:19 UTC
Dave asked me to add this one

[skadz@codewarrior ~]$ rpm -q gtkhtml3
gtkhtml3-3.6.2-1



Comment 8 Dave Malcolm 2005-07-28 20:13:42 UTC
Looks like a general problem with printing; reassigning to libgnomeprint, and
changing summary. 

From talking to owen on IRC it sounds like it's fixed in upstream libgnomeprint
CVS and he's got a workaround in pango 1.9.1; hopefully should be fixed in
tomorrow's rawhide.



Comment 9 Owen Taylor 2005-07-28 21:04:21 UTC
Updated Pango packages built.


Comment 10 Tom Duffy 2005-07-29 18:08:45 UTC
verfied: this is fixed in today's rawhide.


Note You need to log in before you can comment on or make changes to this bug.