Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163439 - yumex package missing dependencies
Summary: yumex package missing dependencies
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex
Version: 4
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-16 16:46 UTC by Lamont Peterson
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-17 09:48:58 UTC


Attachments (Terms of Use)

Description Lamont Peterson 2005-07-16 16:46:47 UTC
Description of problem:  
The yumex package does not depend on the glade2 package.  If glade2 is not 
installed,  yumex fails to run. 
  
I built this system by starting with a "minimal" install, stripping about 100  
packages off of that and then adding only what I needed/wanted.  "yum install  
yumex" successfully ran and, IIRC, included a couple of dependencies or so.  
  
Version-Release number of selected component (if applicable):  
yumex-0.40-5.1.fc4  
  
How reproducible:  
With glade2 *not* installed, install yumex (prefereably with yum, but 
whatever)  
  
Steps to Reproduce:  
1.  Perform a minimal install, without GNOME. 
2.  Install yumex 
3.  Try to run yumex, missing glade support is indicated by fatal launch  
errors. 
    
Actual results:  
# yumex 
Traceback (most recent call last): 
  File "/usr/share/yumex/yumex.py", line 23, in ? 
    import yumWrapper 
  File "/usr/share/yumex/yumWrapper.py", line 48, in ? 
    from YumexUtils import * 
  File "/usr/share/yumex/YumexUtils.py", line 23, in ? 
    import gtk.glade 
ImportError: No module named glade 
  
Expected results:  
yumex should run, as the installation of the RPM should depend on whatever 
package is missing that is causing this error (it is *not* the glade2 package, 
see below). 
  
Additional info:  
If you want me to write a patch for the SPEC file, I will.  I figured that  
this kind of one-liner would just be easier for you to fix without a SPEC  
patch. 
 
I have manually (I say manually as in "I had to use a separate yum comand") 
installed glade2 and found that it did not provide whatever is missing.  Here 
is a listing of some (possibly) related packages I have on this system: 
 
$ rpm -qa *glade* 
libglade2-devel-2.5.1-2 
libglade2-2.5.1-2 
 
I build RPMs on this system.  I do not remember when the libglade2-devel 
package got installed, but I am sure that is the reason why.

Comment 1 Tim Lauridsen 2005-07-17 09:48:58 UTC
It is pygtk2-libglade you are missing
I have added 
Requires: pygtk2-libglade
to my SPEC file in CVS, it will be included in the next release.


Note You need to log in before you can comment on or make changes to this bug.