Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163432 - Installer crashes on disk partioning
Summary: Installer crashes on disk partioning
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: ia64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: FCMETA_INSTALL
TreeView+ depends on / blocked
 
Reported: 2005-07-16 10:54 UTC by Simon
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-18 08:46:05 UTC


Attachments (Terms of Use)
Anaconda dump file after disk partitioning failed. (deleted)
2005-07-16 10:56 UTC, Simon
no flags Details

Description Simon 2005-07-16 10:54:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
FC4 installer crashed when on disk partitioning phase. There are 2 SATA drives in my PC, and installing FC4 to second disk (/dev/sdb). First attempt was a manual configuration, second attempt was default using LVM. /dev/sda contains 2 NTFS partitions with Windows XP installed. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.In disk partitioning setup, choose automatic disk partitioning, installing to /dev/sdb.
  

Actual Results:  Got the anaconda dump which I saved to floppy.

Expected Results:  Expected the partitioning to happen successfully, and FC4 to install.

Additional info:

Comment 1 Simon 2005-07-16 10:56:43 UTC
Created attachment 116838 [details]
Anaconda dump file after disk partitioning failed.

Comment 2 Jeremy Katz 2005-07-18 19:15:33 UTC
Looks like things were going badly due to overrunning some space available with
spamming of the following in the logs:
  <4>drivers/usb/input/hid-core.c: input irq status -75 received
  <4>drivers/usb/input/hid-core.c: input irq status -75 received

Comment 3 Pete Zaitcev 2005-07-18 19:45:28 UTC
So, does it all work when using a different keyboard or mouse?


Comment 4 Pete Zaitcev 2005-09-08 21:06:37 UTC
This symptom is typical for the Microsoft Natural keyboard.
If for some reason a report was not read, next report is appended
to the previous one and the result is a persistent bubble condition.
Is this a Microsoft keyboard? Does other keyboard work?

Comment 5 Dave Jones 2005-09-30 23:53:04 UTC
http://fedora.isphuset.no/ contains an unofficial Fedora 4.1, which may get you
up and running, as it has a install kernel based on one of the errata kernels.

Comment 6 Pete Zaitcev 2005-10-18 08:46:05 UTC
Simon seems to be uncooperative, which is too bad, because I just had
a thremendous idea how to handle the Microsoft Natural and the bubble
condition. But it needs a strong reproducer. Closing as "buy a different
keyboard".



Note You need to log in before you can comment on or make changes to this bug.