Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163426 - Package manager does not resolve dependencies, requires constant disc switching
Summary: Package manager does not resolve dependencies, requires constant disc switching
Keywords:
Status: CLOSED DUPLICATE of bug 160475
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-packages
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-16 05:38 UTC by Steve
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-28 14:08:29 UTC


Attachments (Terms of Use)

Description Steve 2005-07-16 05:38:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I have FC4 on 4 cd's. If I add or remove applications with system-config-packages sometimes it will not all me to and provide an error that it cannot update becasue the packages required are not available. 
..
add remove when it does allow 'update' the packager will not organize the packages I am trying to install. If it tells me 2 discs are needed, I will have to switch discs depending on whitch disc has the part of the package I am trying to install.
..
It would also be nice to integrate yum with package manager.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
Add a package
1. Open package manager
2. Attempt to add Eclipse Development Environment
3. click update
4. see error message that states their are dependency issue- a list of programs will appear that also need to be installed, but package manager doesn't automatically install them
..
Succesfully updating, but using 2 or more discs..
1. I will constantly have to switch dics depending on where packages are located
2. I may have to switch between dics 1 and 2 multiple times.
  

Actual Results:  As stated

Expected Results:  Package manager should automatically detect dependencies when adding or removing programs
..
Package manager should organize the specific programs it needs acoring to what disc they are on. So once I've inserted a disc to add programs, I should not have to reinsert that disc later. Once disc 1 is used, it should not have to be used again.

Additional info:

Everytime I have an added package that requires more than one disc, I constantly have to switch discs when I should only have to use them once.

Comment 1 Máirín Duffy 2005-07-28 14:08:29 UTC

*** This bug has been marked as a duplicate of 160475 ***


Note You need to log in before you can comment on or make changes to this bug.