Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163424 - KDM fail to start normally, because is missing kdmtheme
Summary: KDM fail to start normally, because is missing kdmtheme
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-16 04:06 UTC by Sergio Monteiro Basto
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-27 18:39:25 UTC


Attachments (Terms of Use)

Description Sergio Monteiro Basto 2005-07-16 04:06:37 UTC
Description of problem:

Still can agree with what is write on Bugzilla Bug 154977
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=154977
but now in FC4 final release 

Version-Release number of selected component (if applicable):
kdebase-3.4.1-0.fc4.1.i386.rpm

How reproducible:
Set DISPLAYMANAGER="KDE" in /etc/sysconfig/desktop

Steps to Reproduce:
1. after set DISPLAYMANAGER="KDE", reboot computer.

  
Actual results:
all blue background screen login

Expected results:
fedora bacakground screen login with clock 


Additional info:

I would like to know :D, what I have to change in spec file to compile kdebase
(from kdebase-3.4.1-0.fc4.1.src.rpm) with the KDM-Theme Manager (kdemtheme) ?

Comment 1 Ngo Than 2005-07-18 11:51:02 UTC
the fedora background is included in fedora-logos package, you should install
this package. To have kdmtheme in KDE, you have to download it from the
following website: http://www.kde-look.org/content/show.php?content=22120 and
rebuild it for FC4.



Comment 2 Sergio Monteiro Basto 2005-07-18 18:58:07 UTC
Hi
I think I don't explain my self very well, after file this bug I realize that
Fedora Logos appears on my KDM, but appears one Default KDE theme (with a all
blue background) that is not the default FEDORA theme (with the default fedora
background).

Well with some luck, I found the bug.
on /etc/X11/xdm/kdmrc
UseTheme=true make the bug.

-UseTheme=true
+#UseTheme=true
after apply this diff, kdm back to normal.

Thanks.

Comment 3 Ngo Than 2005-07-18 19:15:30 UTC
it's intended to enable UseTheme as default in FC4. If you don't want it, you
should disable it manually as you have done above or just use kdmtheme tool to
disable it. it's not a bug!

Comment 4 Sergio Monteiro Basto 2006-01-14 18:03:41 UTC
After upgrade to kde 3.5 I got same issue ,

the upgrade overwrite /etc/X11/xdm/kdmrc

and UseTheme still not avaible ,

so copy old kdmrc over new one 

cp /etc/X11/xdm/kdmrc.rpmsave /etc/X11/xdm/kdmrc


Comment 5 Ngo Than 2006-09-27 18:39:25 UTC
ok, i added FedoraBubble theme for KDM, it will have the same look as GDM. 
This problem will be fixed in new kdebase-3.5.4-0.6.fc5. Thanks for your 
report.


Note You need to log in before you can comment on or make changes to this bug.