Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163416 - /usr/sbin/system-install-packages fails if cwd has spaces in name
Summary: /usr/sbin/system-install-packages fails if cwd has spaces in name
Keywords:
Status: CLOSED DUPLICATE of bug 151621
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-packages
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-16 01:27 UTC by Edward J. Huff
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-21 20:02:49 UTC


Attachments (Terms of Use)

Description Edward J. Huff 2005-07-16 01:27:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
exec python /usr/share/system-config-packages/SinglePackageWindow.py $*

should read

exec python /usr/share/system-config-packages/SinglePackageWindow.py "$*"


Version-Release number of selected component (if applicable):
system-config-packages-1.2.25-1

How reproducible:
Always

Steps to Reproduce:
1. mkdir 'two words'
2. cd 'two words'
3. /usr/bin/system-install-packages $(pwd)/foo.rpm


Actual Results:  After entering root password, got an alert:

Could not open package.
The file '/home/user/two' could not be read.
Make sure you have ...


Expected Results:  After entering root password, got an alert:

Could not open package.
The file '/home/user/two words/foo.rpm' could not be read.
Make sure you have ...


Additional info:

fgrep '$*' /usr/sbin/* shows a number of similar bugs.

Comment 1 Jeremy Katz 2005-09-21 20:02:49 UTC

*** This bug has been marked as a duplicate of 151621 ***


Note You need to log in before you can comment on or make changes to this bug.