Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163411 - top doesn't use saved configuration
Summary: top doesn't use saved configuration
Keywords:
Status: CLOSED DUPLICATE of bug 161449
Alias: None
Product: Fedora
Classification: Fedora
Component: procps
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-15 22:29 UTC by Craig Goodyear
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-17 08:47:58 UTC


Attachments (Terms of Use)

Description Craig Goodyear 2005-07-15 22:29:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
The custom configuration for top that I save with the W command is not 
used the next time that top is started. 

After I change the configuration of top, I use the W command to save the 
configuration, and the ~/.toprc file is written to the hard disk. 
But after closing top and restarting, the default configuration is used 
instead of the new configuration.

Version-Release number of selected component (if applicable):
procps-3.2.5-6.3

How reproducible:
Always

Steps to Reproduce:
1. start top and change some of its configuration
2. use the W command to save the new configuration
3. close top
4. restart top
  

Actual Results:  The built in default configuration for top is used instead of the custom 
configuration.


Expected Results:  The new custon configuration should be used.

Additional info:

Comment 1 Karel Zak 2005-07-15 22:59:33 UTC
It's already reported problem (see bug #161449) and it should be fixed exactly
in procps-3.2.5-6.3. Do have really this version (check "rpm -qf `whereis -b
top` 2> /dev/null") ?

I cannot reproduce it any more. Please, try:

  rm ~/.toprc   (or mv ~/.toprc ~/.toprc.backup)
  start top
  press 'c'
  press 'W'
  stop top (press 'q')
  start it again

and there should be full command lines after startup.

Comment 2 Craig Goodyear 2005-07-16 20:38:16 UTC
I am using procps-3.2.5-6.3.  Deleting ~/.toprc does allow top to work 
correctly.  I had not tried removing that file previously.  You are correct, 
this bug is fixed.


Comment 3 Karel Zak 2005-07-17 08:47:58 UTC
Thanks for confirmation.

*** This bug has been marked as a duplicate of 161449 ***


Note You need to log in before you can comment on or make changes to this bug.