Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163410 - Update kernel 2.6.12-1.1372_FC3 is missing 'build' directory
Summary: Update kernel 2.6.12-1.1372_FC3 is missing 'build' directory
Keywords:
Status: CLOSED DUPLICATE of bug 163406
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-15 22:27 UTC by Mark Adams
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-15 23:16:33 UTC


Attachments (Terms of Use)

Description Mark Adams 2005-07-15 22:27:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
The just released FC3 update kernel 2.6.12 is missing the 'build' directory in /lib/modules/2.6.12-1.1372_FC3/. Instead, there is a dangling symlink to ../../../usr/src/kernels/2.6.12-1.1372_FC3-x86_64

The previous FC3 kernels didn't require the kernel source to be installed to build external modules, so I presume this is a packaging oversight.


Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1372_FC3

How reproducible:
Always

Steps to Reproduce:
1. Update kernel to 2.6.12-1.1372_FC3
2. Try to build an external module (such as Nvidia drivers)
3.
  

Actual Results:  The build fails as the necessary files to build external modules are missing.


Expected Results:  /lib/modules/2.6.12-1.1372_FC3/build should exist and be populated as per previous FC3 kernels.


Additional info:

Comment 1 Adam Bowns 2005-07-15 22:39:34 UTC
Confirmed, I have the same issue but on i386 so it looks like the problem spans
the different arch releases also.

Comment 2 Adam Bowns 2005-07-15 22:44:14 UTC
This looks like a dupe of Bug 163406

Comment 3 Dave Jones 2005-07-15 23:16:33 UTC

*** This bug has been marked as a duplicate of 163406 ***


Note You need to log in before you can comment on or make changes to this bug.