Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163391 - Build of GLibC fails several self-tests on i686 system
Summary: Build of GLibC fails several self-tests on i686 system
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-15 19:56 UTC by Steve Snyder
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-18 16:00:40 UTC


Attachments (Terms of Use)
Log file generated by the "make check" suite of GLibC self-tests (deleted)
2005-07-15 19:59 UTC, Steve Snyder
no flags Details

Description Steve Snyder 2005-07-15 19:56:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050520 Fedora/1.7.8-1.icc

Description of problem:
In the course of rebuilding the binary GLibC RPMs, the automatic self test ("make check") fails several nptl-related tests.

Version-Release number of selected component (if applicable):
glibc-2.3.4-2.9

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL4 with "[]Everything" package selection
2. Install all available updates.
3. Run: "rpmbuild --rebuild --target i686 glibc-2.3.4-2.9.src.rpm"
  

Actual Results:  Here's an example of failure.  See the attached log for the full list of errors.

Failed to kill test process: No child processes
make[2]: *** [/home/rpmbuild/BUILD/glibc-2.3-20050218T0151/build-i686-linuxnptl/nptl/tst-eintr2.out] Error 1
Failed to kill test process: No child processes
make[2]: *** [/home/rpmbuild/BUILD/glibc-2.3-20050218T0151/build-i686-linuxnptl/nptl/tst-eintr3.out] Error 1
Failed to kill test process: No child processes
make[2]: *** [/home/rpmbuild/BUILD/glibc-2.3-20050218T0151/build-i686-linuxnptl/nptl/tst-eintr5.out] Error 1


Expected Results:  None of the self-tests should fail.


Additional info:

This is on a Pentium3-based machine with kernel 2.6.9-11.EL.

Comment 1 Steve Snyder 2005-07-15 19:59:18 UTC
Created attachment 116819 [details]
Log file generated by the "make check" suite of GLibC self-tests

Comment 2 Jakub Jelinek 2005-07-18 15:48:37 UTC
Works just fine here.

Comment 3 Jos Vos 2005-07-18 15:57:06 UTC
Same here when rebuilding glibc on a dual Xeon machine (on a RHEL4 rebuild): I
see exactly the same problems.  Also having problems on x86_64, not exactly the
same, it seems, but still fatal.

Note that if you kill a hanging process, the build proceeds and finally produces
binary rpm's.  It looks like the "make ... | tee check.log || :" is not doing
what it should do (will try to further analyze this).


Comment 4 Jakub Jelinek 2005-07-18 16:00:40 UTC
(on a RHEL4 rebuild)
^^^^^^^^^^^^^^^^^^^^
Then you are using a different kernel, and if those tests fail, that is most
likely a kernel problem.

Comment 5 Jos Vos 2005-07-18 16:23:54 UTC
Well, the original submitter said he was using a RHEL4 U1 system.

Another issue w.r.t. the spec file is: *if* thoses tests fail, the "make ... |
tee" hangs until you kill something.  I don't know if something can be improved
here.

Anyway, I'll leave the bug closed and try to solve it myself ;-).


Note You need to log in before you can comment on or make changes to this bug.