Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163382 - openssh-askpass package not updated & depends on openssh
Summary: openssh-askpass package not updated & depends on openssh
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: openssh
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-15 18:42 UTC by Lamont Peterson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-15 21:31:39 UTC


Attachments (Terms of Use)

Description Lamont Peterson 2005-07-15 18:42:12 UTC
Description of problem: 
Installation of openssh-askpass (w/yum, etc.) fails because the base package 
depends on openssh of the same version.  Errata have been released but not all 
(sub-)packages were built, including openssh-askpass. 
 
As the openssh-askpass (erroneously?) depends on the openssh package of the 
same version, yum/rpm does not want to in stall the package from base, as an 
errata for the depended upon package already exists and is, of course, already 
installed. 
 
Version-Release number of selected component (if applicable): 
openssh-askpass-4.0p1 
openssh-4.1p1 
 
How reproducible: 
Install FC4 w/openssh but without openssh-askpass, update openssh and try to 
"yum install openssh-askpass". 
 
Steps to Reproduce: 
1.  Have openssh installed and errata applied on FC4 and do not have 
openssh-askpass installed 
2.  Try to install openssh-askpass 
3.  Read dependency error. 
   
Actual results: 
Installation fails because of missing pegged dependency. 
 
Expected results: 
There should either be an errata of the openssh-askpass package which matches 
the openssh package or (even better) the openssh-askpass package should not be 
pegged to a specific version of the openssh package.

Comment 1 Tomas Mraz 2005-07-15 21:31:39 UTC
This package update was released normally with all subpackages including
openssh-askpass - look at
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/$arch/
In every arches there is openssh-askpass-4.1p1-3.1 package.

This must have been some glitch on a mirror you use for downloading updates or
something similar.



Note You need to log in before you can comment on or make changes to this bug.