Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163378 - kickstart.py exception at line 1559 in setGroupSelection
Summary: kickstart.py exception at line 1559 in setGroupSelection
Keywords:
Status: CLOSED DUPLICATE of bug 160209
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-15 18:17 UTC by nkraft
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-15 19:42:09 UTC


Attachments (Terms of Use)

Description nkraft 2005-07-15 18:17:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
When performing a kickstart and using the "-package" syntax in the %packages section, there is an exception in /usr/lib/anaconda/kickstart.py at line 1559 in setGroupSelection.  On line 1558 there is a hasKey check for variable "n", but line 1559 uses variable "name" as a key, so this appears to be a simple programming error.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Add "-doxygen" (or any package) to the %packages section of the kickstart file.
2.Initiate kickstart using DVD iso over nfs.

Additional info:

Comment 1 Chris Lumens 2005-07-15 19:42:09 UTC

*** This bug has been marked as a duplicate of 160209 ***


Note You need to log in before you can comment on or make changes to this bug.