Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163376 - gfortran internal compiler error: Segmentation fault
Summary: gfortran internal compiler error: Segmentation fault
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-15 17:27 UTC by Orion Poplawski
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 4.1.0-0.15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-18 08:18:05 UTC


Attachments (Terms of Use)
Fortran source for the above compile (deleted)
2005-07-15 17:27 UTC, Orion Poplawski
no flags Details

Description Orion Poplawski 2005-07-15 17:27:17 UTC
Description of problem:

This is trying to compile NCAR Graphics 4.4.1 with gfortran:

$ gfortran -c gesc.f
gesc.f: In function 'gesc':
gesc.f:237: internal compiler error: Segmentation fault


Version-Release number of selected component (if applicable):
gcc-gfortran-4.0.0-8


How reproducible:
everytime

Comment 1 Orion Poplawski 2005-07-15 17:27:17 UTC
Created attachment 116812 [details]
Fortran source for the above compile

Comment 2 Orion Poplawski 2005-07-15 17:31:41 UTC
This appears to be in the GCC bugzilla: 
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=21406 , duplicate of:
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=15966

Comment 3 Jakub Jelinek 2005-07-18 08:29:26 UTC
Then it is also fixed in gcc-gfortran-4.0.1-3 in rawhide.

Comment 4 Orion Poplawski 2005-07-18 22:36:28 UTC
Any chance we'll see an update that fixes this for FC4?

Comment 5 Orion Poplawski 2005-07-28 16:48:55 UTC
Well, not completely fixed.  With gcc-gfortran-4.0.1-4.fc4 I get:

$ gfortran -c gesc.f
gesc.f: In function 'gesc':
gesc.f:237: internal compiler error: in gfc_convert_array_to_string, at
fortran/trans-io.c:414
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.

Perhaps not all of the fixes in pr15966 are in, or this is a new bug?  Don't see
the exact message in the gcc bugzilla, but obviously this is still related.

Comment 6 Jakub Jelinek 2005-08-21 18:26:36 UTC
Minimal testcase is:
subroutine foo(x,y)
integer x, z
character*(*) y(x)
read(y,500) z
return
500 format(I10)
end subroutine


Comment 7 Jerry 2005-09-03 07:44:42 UTC
The testcase given in Comment #6 does not give me an error with 4.1 build with
patches for array I/O incorporated.  Evidently its fixed.  Soon as we submit
these patches for review this can be confirmed by others.

Comment 8 Jakub Jelinek 2006-01-18 08:18:05 UTC
Yeah, fix verified with gcc-gfortran-4.1.0-0.15 in rawhide.
WONTFIX for gcc 4.0.x.


Note You need to log in before you can comment on or make changes to this bug.