Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163372 - Perl action messages need to be used in java.
Summary: Perl action messages need to be used in java.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/R&D
Version: RHN Devel
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ken Ganong
QA Contact: Shannon Hughes
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-15 16:02 UTC by Ken Ganong
Modified: 2007-04-18 17:29 UTC (History)
1 user (show)

Fixed In Version: RHN 4.0.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-01 03:00:59 UTC


Attachments (Terms of Use)

Description Ken Ganong 2005-07-15 16:02:44 UTC
Description of problem:
Action messages (The messages in the navy bluish bar near the top of a page)
that are created on a perl web page cannot be read on a java page.

Reproduce:
Go to systems, click a system, delete the system.  You are brought to the system
overview page without a message telling you that you have just deleted a system.
 Now go to a pxt page.  The message appears.

Expected results:
Messages will appear on the correct page regardless of whether that page is perl
or java.

Additional info:
These messages are saved in a session object on both sides.  Neither side can
understand the other's session object.  Since we are going to Java pretty soon,
we are not going to engineer a way to unstand perl session objects.  Instead, we
will deal with each instance separately and pass the required information
through the request to the java page without pushing a message to the session.  


So far the known times that a message need to go across the perl/java line are:
Creating a Server Group.
Deleting a Server Group.
Deleting a Server.
Deleting Servers (SSM).

Comment 1 Bret McMillan 2005-07-26 02:53:48 UTC
qa contact == shughes

Comment 2 Ken Ganong 2005-07-26 14:15:10 UTC
Test Plan:

See Reproduce and Expected Results above.
The message should appear only once, on the page immediately after the action. 
Browsing to one perl and one java page is enough to verify that the message only
appears once.

This bug applies to any time an action is taken on the website that would
produce a message on the immediately following page AND the start and end page
are not written in the same language (perl to java or java to perl).  So far,
the only known times this bug occurs there is a perl to java page order.  These
known times are given in the previous comment.

Comment 3 Shannon Hughes 2005-07-26 17:20:26 UTC
looks good on qa


Note You need to log in before you can comment on or make changes to this bug.