Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163363 - Installer hangs during network kickstart after disk setup complete
Summary: Installer hangs during network kickstart after disk setup complete
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-15 14:23 UTC by Network Operations
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-21 21:07:31 UTC


Attachments (Terms of Use)

Description Network Operations 2005-07-15 14:23:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Getting the following message during a network kickstart - machine is booting off the network with PXE and the kickstart points to an NFS mount on the server and installs via VNC. Everything goes OK until after the disk partitioning, then clicking next gives the error:


Traceback (most recent call last):
 File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
  self.dispatch.gotoNext()
 File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
  self.moveStep()
 File "/usr/lib/anaconda/dispatch.py", line 242, in MoveStep
  rc = apply(func, self.bindArgs(args))
 File "/usr/lib/anaconda/packages.py", line 207, in readPackages
  id.instClass.setGroupSelection(grpset, intf)
 File "/usr/lib/anaconda/kickstart.py", line 1559, in setGroupSelection
  pkgs = grpset.hdrlist.pkgnames[name]
KeyError: "

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot machine on network
2. wait for VNC to start
3. accept the defaul partitioning
  

Actual Results:  Traceback (most recent call last):
 File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
  self.dispatch.gotoNext()
 File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
  self.moveStep()
 File "/usr/lib/anaconda/dispatch.py", line 242, in MoveStep
  rc = apply(func, self.bindArgs(args))
 File "/usr/lib/anaconda/packages.py", line 207, in readPackages
  id.instClass.setGroupSelection(grpset, intf)
 File "/usr/lib/anaconda/kickstart.py", line 1559, in setGroupSelection
  pkgs = grpset.hdrlist.pkgnames[name]
KeyError: "

Expected Results:  Automatic installation of packages from the kickstart file...

Additional info:

Comment 1 Jeremy Katz 2005-07-18 19:10:54 UTC
Can you provide the complete traceback you received?

Comment 2 Jeremy Katz 2005-09-21 21:07:31 UTC
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.  If you have further details, feel free to
reopen the report with the additional details attached.

Comment 3 Network Operations 2005-09-22 08:18:49 UTC
I believe the above is the complete traceback, as for not reproducable, do you
actually read the bug reports - "How reproducible: Always".


Note You need to log in before you can comment on or make changes to this bug.