Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163357 - Bad: when trying to change xmms font while it is running X crashes due to problems with SELinux
Summary: Bad: when trying to change xmms font while it is running X crashes due to pro...
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xmms
Version: 4
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-15 14:11 UTC by hipodilski
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-01 14:16:17 UTC


Attachments (Terms of Use)

Description hipodilski 2005-07-15 14:11:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.7.8-2

Description of problem:
When i go to options -> preferences -> fonts -> browse and select "andale mono" as a font the X server crash. Here is what i get in /var/log/messages.
Jul 15 16:05:23 davidian dbus: avc:  1 AV entries and 1/512 buckets used, longest chain length 1
Jul 15 16:05:23 davidian gconfd (hipo-3082): Received signal 15, shutting down cleanly
Jul 15 16:05:24 davidian gdm[2960]: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
Jul 15 16:05:24 davidian gdm(pam_unix)[2960]: session closed for user hipo
Jul 15 16:05:24 davidian gpm[2565]: *** info [mice.c(1766)]:
Jul 15 16:05:24 davidian gpm[2565]: imps2: Auto-detected intellimouse PS/2
Jul 15 16:05:25 davidian gconfd (hipo-3082): Exiting
Jul 15 16:05:25 davidian su(pam_unix)[26433]: session closed for user root

I'm running fedora core 4 i do upgrade from fedora core 3 with apt-get using freshrpms.net. 
[root@davidian info]# cat /etc/fedora-release
Fedora Core release 4 (Stentz)
[root@davidian info]#
[root@davidian info]# uname -a;
Linux davidian 2.6.11-1.1369_FC4 #1 Thu Jun 2 22:55:56 EDT 2005 i686 athlon i386 GNU/Linux
[root@davidian info]#

[root@davidian info]# cat /proc/cpuinfo |grep -i athlon
model name      : AMD Athlon(tm) XP 2000+
[root@davidian info]#

I'll try to upgrade xmms with newer a.k.a. ending on fc4 but anyway it's totally  not logical to crash X when trying to change the playlist font in xmms.
I'm currently logged with user:
[hipo@davidian info]$ id
uid=500(hipo) gid=500(hipo) groups=500(hipo) context=user_u:system_r:unconfined_t
[hipo@davidian info]$


regards


Version-Release number of selected component (if applicable):
xmms-1.2.10-11.1.1.fc3.rf

How reproducible:
Always

Steps to Reproduce:
1. run xmms
2. go to options -> preferences -> fonts -> browse
3. select the "andale mono" font
  

Actual Results:  X crashes

Expected Results:  Change the font of the playlist in xmms

Additional info:

Comment 1 hipodilski 2005-07-15 14:16:31 UTC
Sorry but probably i'm mistaken. I'm not sure is this bug related to SELinux but
when the X crashed i saw some bulky logs from the SELinux on my console and that
gives me the idea the problem could be related to that. Anywayz checking my
/var/log/messages later i didn't discovered lines stating direct errors with
SELinux, just logs from the services it handles like crontab and stuff.

Comment 2 John (J5) Palmieri 2005-07-15 14:33:06 UTC
xmms has moved to fedora extras

Comment 3 Matthias Saou 2005-08-04 17:11:33 UTC
- Could you try to install the xmms package from Extras instead as you suggested
and try again?
- It would probably be interesting to check the /var/log/Xorg.* files too.

Anyway, I really doubt this is a bug in xmms, since no user applications should
be able to crash the X server (well, not if they aren't suid root or such).
Still, we need to get more information to be able to reassign the bug to the
right component.

Comment 4 Matthias Saou 2006-06-30 14:30:59 UTC
Reassigning to the current maintainer (Ville).

Comment 5 Ville Skyttä 2006-07-01 14:16:17 UTC
It's been almost a year since the request for additional info with no feedback,
so closing.  If the problem persists in FC5+, make sure that you are running
xmms from Fedora Extras, and try to obtain a stack trace as outlined in
http://fedoraproject.org/wiki/StackTraces, and feel free to reopen.  Also, try
to reproduce with some of the fonts included in FC/FE.


Note You need to log in before you can comment on or make changes to this bug.