Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163355 - toshiba_acpi.ko falis to load properly
Summary: toshiba_acpi.ko falis to load properly
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: FCMETA_ACPI
TreeView+ depends on / blocked
 
Reported: 2005-07-15 14:08 UTC by Tom London
Modified: 2015-01-04 22:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-18 16:20:24 UTC


Attachments (Terms of Use)

Description Tom London 2005-07-15 14:08:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050623 Fedora/1.0.4-5 Firefox/1.0.4

Description of problem:
Toshiba acpi module no longer loads properly:

Jul 15 07:00:56 localhost modprobe: FATAL: Error inserting toshiba_acpi (/lib/modules/2.6.12-1.1433_FC5/kernel/drivers/acpi/toshiba_acpi.ko): No such device
Jul 15 07:01:00 localhost kernel: toshiba_acpi: Using generic hotkey driver
Jul 15 07:01:00 localhost kernel: toshiba_acpi: Using generic hotkey driver

Up until yesterday, I used to get:
Jul 14 06:24:58 localhost kernel: toshiba_acpi: Toshiba Laptop ACPI Extras version 0.18
Jul 14 06:24:58 localhost kernel: toshiba_acpi:     HCI method: \_SB_.VALZ.GHCI


Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1433_FC5

How reproducible:
Always

Steps to Reproduce:
1. boot, or 'modprob4e -v toshiba_acpi'
2.
3.
  

Additional info:

Comment 1 Tom London 2005-07-15 23:22:12 UTC
Here is the 'tail' from running 'strace modprobe -v toshiba_acpi':

open("/lib/modules/2.6.12-1.1433_FC5/kernel/drivers/acpi/toshiba_acpi.ko",
O_RDWR) = 3
fcntl64(3, F_SETLKW, {type=F_WRLCK, whence=SEEK_SET, start=0, len=1}) = 0
fcntl64(3, F_GETFL)                     = 0x2 (flags O_RDWR)
fstat64(3, {st_mode=S_IFREG|0744, st_size=8584, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0xb7f0b000
_llseek(3, 0, [0], SEEK_CUR)            = 0
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\1\0\3\0\1\0\0\0\0\0\0\0"..., 16384) = 8584
read(3, "", 4096)                       = 0
read(3, "", 4096)                       = 0
read(3, "", 4096)                       = 0
fstat64(1, {st_mode=S_IFCHR|0620, st_rdev=makedev(136, 1), ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0xb7f0a000
write(1, "insmod /lib/modules/2.6.12-1.143"..., 75insmod
/lib/modules/2.6.12-1.1433_FC5/kernel/drivers/acpi/toshiba_acpi.ko
) = 75
init_module("ELF", 0x2188)          = -1 ENODEV (No such device)
write(2, "FATAL: Error inserting toshiba_a"..., 121FATAL: Error inserting
toshiba_acpi
(/lib/modules/2.6.12-1.1433_FC5/kernel/drivers/acpi/toshiba_acpi.ko): No such device
) = 121


Comment 2 Dave Jones 2005-08-04 19:21:57 UTC
What model laptop are you trying to run this on ?


Comment 3 Tom London 2005-08-04 20:22:05 UTC
Toshiba Tecra M2-S530

This worked until the update of 7/14.  Still 'broken'.

Comment 4 Len Brown 2005-08-04 20:27:00 UTC
> toshiba_acpi: Using generic hotkey driver

Bzzzt!  Wrong answer:-)

Please build with CONFIG_ACPI_HOTKEY=n
(the default in 2.6.13)
This EXPERIMENTAL driver is still under development
and should not yet be shipped as part of Fedora.


Comment 5 Dave Jones 2005-08-05 22:33:02 UTC
*confused*. This bug is filed against rawhide/FC5, and comment #1 suggests
you're using those kernels.

Yet in those kernels...

# CONFIG_ACPI_HOTKEY is not set

and its been this way since July 13th, which is roughly when that option
appeared iirc.


I'm guessing you're testing this on FC4 kernels now ? (Which are broken, I'll
fix it in the next update).


Comment 6 Tom London 2005-08-06 18:19:28 UTC
No, I'm testing this on Rawhide kernels.  Current running one is
2.6.12-1.1451_FC5 (still fails with messages as in #1). (I am downlownloading 
2.6.12-1.1452_FC5 now.)

grep HOTKEY /boot/config*1451*
# CONFIG_ACPI_HOTKEY is not set

July 13 is roughly when this stopped working.

What additional info can I provide to help?

Comment 7 Tom London 2005-08-18 15:30:26 UTC
This started working again this morning with 2.6.12-1.1492_FC5.

Didn't see anything in the posted changelog; was this fixed in 2.6.13-rc6-git9?

Comment 8 Dave Jones 2005-08-18 16:20:24 UTC
looks like it. there were a bunch of acpi hotkey fixes there.



Note You need to log in before you can comment on or make changes to this bug.