Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163348 - clock-applet freezes . . .
Summary: clock-applet freezes . . .
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-15 12:54 UTC by Need Real Name
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-11-13 09:04:40 UTC


Attachments (Terms of Use)
gdb /usr/libexec/clock-applet 2672 (deleted)
2005-09-28 09:33 UTC, Need Real Name
no flags Details
stack trace of frozen clock (deleted)
2005-10-10 06:14 UTC, Need Real Name
no flags Details
A decent stracktrace (deleted)
2005-10-27 09:43 UTC, Need Real Name
no flags Details

Description Need Real Name 2005-07-15 12:54:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Epiphany/1.6.3

Description of problem:
The clock-applet freezes, leading me to believe that it still really is 13:38 (or whatever time).

I can't reproduce this, but this is the second time this has happened.
The machine I am running it on is not rebooted very often.

An strace of the process shows no activity, not even a multitide of gettimeofday calls.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
X

Additional info:

This is pretty important - you need to be able to trust the time on a clock.

Comment 1 Need Real Name 2005-07-15 15:52:43 UTC
It's just frozen again!
Twice in one day!

gnome-applets-2.10.1-9

Comment 2 Mark McLoughlin 2005-07-18 08:17:06 UTC
Best thing to try is to get a stack trace of the clock-applet process when its
frozen - don't forget to install the gnome-panel-debuginfo package first

  http://fedora.linux.duke.edu/wiki/StackTraces

Comment 3 Need Real Name 2005-09-28 09:33:20 UTC
Created attachment 119354 [details]
gdb /usr/libexec/clock-applet 2672

Output from gdb thread apply all bt.
It doesn't look very useful..

Comment 4 Need Real Name 2005-10-10 06:14:38 UTC
Created attachment 119757 [details]
stack trace of frozen clock

This one looks better!

Comment 5 Need Real Name 2005-10-14 12:16:07 UTC
This shouldn't be NEEDINFO_REPORTER, and I can't change this back to ASSIGNED.

Comment 6 Need Real Name 2005-10-27 09:43:10 UTC
Created attachment 120456 [details]
A decent stracktrace

Another day, another "WHAT?! IT CAN'T BE TWELVE O'CLOCK!!"

This stack trace looks good. Highlights:
#2  0x0366fadc in open_calendar (ecal=0x95d3200, only_if_exists=Variable
"only_if_exists" is not available.

#5  0x08056d64 in calendar_sources_load_sources (sources=Variable "sources" is
not available.

#55 0x0032dec4 in panel_applet_factory_main_closure (
    iid=0x805780c "OAFIID:GNOME_ClockApplet_Factory", applet_type=156384624,
    closure=Variable "closure" is not available.

I know you're busy, but not being able to rely on a desktop clock for
timekeeping is a problem.

Comment 7 Ray Strode [halfline] 2006-08-04 14:14:03 UTC
I think this is an evolution-data-server bug that was fixed quite some time ago.
 Are you still seeing this problem?

Comment 8 Need Real Name 2006-08-04 18:45:00 UTC
I saw it twice last week. Not sure if the strace was the same..

Comment 9 Need Real Name 2006-11-13 09:04:40 UTC
I only see this on one box, so closing.


Note You need to log in before you can comment on or make changes to this bug.