Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163344 - pkg-config --cflags mozilla-nss looks for mozilla-nspr which doesn't exist anymore
Summary: pkg-config --cflags mozilla-nss looks for mozilla-nspr which doesn't exist an...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mozilla
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact: Ben Levenson
URL:
Whiteboard:
: 163398 163489 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-15 12:32 UTC by Caolan McNamara
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-16 16:05:54 UTC


Attachments (Terms of Use)

Description Caolan McNamara 2005-07-15 12:32:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.7.8-2

Description of problem:


Version-Release number of selected component (if applicable):
mozilla-nss-devel-1.7.8-3

How reproducible:
Always

Steps to Reproduce:
1. pkg-config --cflags mozilla-nss

Actual Results:  Package mozilla-nspr was not found in the pkg-config search path.
Perhaps you should add the directory containing `mozilla-nspr.pc'
to the PKG_CONFIG_PATH environment variable
Package 'mozilla-nspr', required by 'NSS', not found


Additional info:

Comment 1 Christopher Aillon 2005-07-15 17:12:52 UTC
Seems the nss pkgconfig generation should take into account whether we built
with system nspr headers or not, will get this looked at.

Comment 2 Christopher Aillon 2005-07-16 03:50:52 UTC
*** Bug 163398 has been marked as a duplicate of this bug. ***

Comment 3 Christopher Aillon 2005-07-16 03:52:06 UTC
Fixed in rawhide.  Requires both nspr-4.6-4 and mozilla-1.7.8-6 to fix the issue.

Comment 4 Ryan Skadberg 2005-07-16 14:22:42 UTC
This upgrade fixed my issues, thanks!

Comment 5 Christopher Aillon 2005-07-16 16:05:54 UTC
Cool. Resolved RAWHIDE.

Comment 6 Caolan McNamara 2005-07-18 10:25:11 UTC
*** Bug 163489 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.