Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163343 - GFS-related kernel modules for smp not installed when applicable
Summary: GFS-related kernel modules for smp not installed when applicable
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: FC6Blocker
TreeView+ depends on / blocked
 
Reported: 2005-07-15 12:18 UTC by Jos Vos
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-21 20:39:27 UTC


Attachments (Terms of Use)
Patch to ignore / pull in kernel module packages (deleted)
2005-07-17 12:22 UTC, Jos Vos
no flags Details | Diff

Description Jos Vos 2005-07-15 12:18:25 UTC
Description of problem:
For a full install on a SMP system, the GFS-kernel-smp package and other
GFS-related SMP kernel (module) packages are not installed.

This is because these packages are excluded in Anaconda, as they otherwise would
pull in the SMP kernel itself on non-SMP systems, but now SMP systems get
installed incompletely.  It would be a good idea to make some provision in
Anaconda that pulls in the smp (and hugemem on RHEL) kernel module packages when
both the corresponding "normal" module package (GFS-kernel in this example) and
the SMP kernel package is installed.

It would also be a good idea to make this code package-independent, so that it
also applies to other packages with kernel modules for various flavors that
might show up in the future, like packages matching "*-kernel-<flavor>". If this
is considered a good idea, I might make a patch for that.

Version-Release number of selected component (if applicable):
10.2.1.5-2

How reproducible:
Do a full install in a SMP system.

Comment 1 Jeremy Katz 2005-07-15 12:23:42 UTC
We'll try to address this in the FC5 timeframe, hopefully with sane kernel
module packaging guidelines :-)

spot is driving that on fedora-packaging.  Will stick on FC5 blocker

Comment 2 Jos Vos 2005-07-15 12:33:51 UTC
Good to hear there will be kernel module guidelines :-) (the guidelines I found
until now were not matching the actual packages, I think).

But I personally need it now for X/OS Linux 4 (RHEL4 rebuild including
RHCS/RHGFS), so I will patch the RHEL4 Anaconda anyway to add the exceptions.  I
already included logic for this in our RHEL3 rebuild (with GFS) in the past, so
that a full install works as expected, but this patch was package-specific.

If I produce something useful, I'll attach a patch here, that probably has to be
changed when the new guidelines are known.

Comment 3 Jos Vos 2005-07-17 12:22:21 UTC
Created attachment 116852 [details]
Patch to ignore / pull in kernel module packages

This patch (against anaconda-10.1.1.19 as found in the current RHEL4) solves
the problem for me.  It is purely based on a package naming convention
(packages matching the RE ".*-kernel(-${KERNEL_FLAVOR})?" are assumed to
contain kernel modules), which works for RHEL4+RHCS+RHGFS, but I guess it needs
to be rewritten for future kernel module packaging guidelines.

Anyway, when I select GFS-kernel on a SMP system, GFS-kernel-smp is pulled in
automagically and so with all module packages, and the "flavor-packages" are
ignored by default.  At least now I don't have to patch anaconda for every
kernel module package I add :-).

Comment 4 Jeremy Katz 2006-09-21 20:39:27 UTC
This is no longer really a concern


Note You need to log in before you can comment on or make changes to this bug.