Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163330 - can't support the "egrep" pattern such as "word\W"
Summary: can't support the "egrep" pattern such as "word\W"
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: cscope
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Frank Ch. Eigler
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-15 06:40 UTC by han pingtian
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-20 20:45:32 UTC


Attachments (Terms of Use)

Description han pingtian 2005-07-15 06:40:13 UTC
Description of problem:
The cscope has a option "Find this egrep pattern:".But when input the "word\W"
and search, it says "Could not find the egrep pattern: word\W". But the egrep
application can find the "word\W".

Version-Release number of selected component (if applicable):
cscope-15.5-12

How reproducible:


Steps to Reproduce:
1.build the cross refences file cscope.out
2.invoke the cscope
3.use the "Find this egrep pattern:" to find a pattern such as "word\W"
  
Actual results:
although the "word\W" exists, but cscope can't find it.

Expected results:
cscope could find the pattern.

Additional info:

Comment 1 Frank Ch. Eigler 2005-07-20 20:45:32 UTC
It turns out there are many versions of egrep.  cscope contains its own little
egrep implementation, probably pulled out of an older SystemV UNIX, which
predates some modern constructs.  Operators like [:alnum:] or \w were not
supported in this version.  I expect that cscope screen's reference to "egrep"
was meant more to indicate that a wider class of regexps are supported than
plain grep: alternation, repetition, and so on.

I hope this explains (my guess at) the reasons for the problem.  Extending
cscope's egrep engine is probably not practical.  I can't think of a different
term to put on the user interface that doesn't suffer from this ambiguity.  I
think we'll have to live with this problem.



Note You need to log in before you can comment on or make changes to this bug.