Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163315 - FC2 raid-1 boot partition not found by FC4 installer for upgrading
Summary: FC2 raid-1 boot partition not found by FC4 installer for upgrading
Keywords:
Status: CLOSED DUPLICATE of bug 163314
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-15 00:22 UTC by Need Real Name
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-15 11:43:17 UTC


Attachments (Terms of Use)

Description Need Real Name 2005-07-15 00:22:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412.6 (KHTML, like Gecko) Safari/412.2

Description of problem:
I have an installation of Fedora Core 4 on a Xeon system with dual SATA drives. The machine was installed 
in FC2 with RAID-1 partitions for /boot, /, /var. /home and swap. When I attempted to upgrade this
machine to FC4 today, the md root partition was found for upgrading and all the partitions were mounted 
by anaconda (according to df in a virtual terminal). However the /boot partition is not found for upgrading 
by anaconda in the Upgrade Boot partition section. Is this a known bug in anaconda? How am I supposed 
to upgrade such a system since the only options I am given is to skip upgrading the boot partition or to 
create a new boot partition (the upgrade the boot partition option is dimmed).
             Jack

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC2 with raid-1 partitions for /, /home, /boot, /var and swap.
2. Attempt to upgrade install FC4 on this machine.


Actual Results:  The Upgrade the Boot Loader step could not find a boot partition to upgrade despite the md for the /boot 
partition having been mounted by anaconda in the previous step.

Expected Results:  The /boot partition should have been found for upgrading by anaconda despite it being on a RAID-1 
partititon.

Additional info:

Comment 1 Jeremy Katz 2005-07-15 11:43:17 UTC

*** This bug has been marked as a duplicate of 163314 ***


Note You need to log in before you can comment on or make changes to this bug.