Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163312 - Resolution of external video from laptop fixed at 800x600
Summary: Resolution of external video from laptop fixed at 800x600
Keywords:
Status: CLOSED DUPLICATE of bug 162733
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-15 00:09 UTC by Graham freeman
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-26 10:07:47 UTC


Attachments (Terms of Use)

Description Graham freeman 2005-07-15 00:09:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040913

Description of problem:
I need to use my laptop with external data projection facilities.  Under an old RedHat system with XFree86, I had no trouble, even if the screen resolution was 1600x1200.  With FC2 and FC4, the resolution I am using on the local screen is 1280x1024.  Only an 800x600 piece of the area gets projected through the video connection.

I have tried this in 3 venues.  With a small portable data projector, I have no problem; the full 1280x1024 is projected.  In the other venues (large halls with fixed facilities), I only get the 800x600 displayed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Connect and turn on the data projector.
2. Boot the computer
3.
  

Actual Results:  800x600 portion of the screen display is projected.  If I move the mouse, the displayed area always tracks the cursor.

Expected Results:  The projected screen should match the screen on the local laptop.

Additional info:

The laptop I am using is an IBM ThinkPad.

Comment 1 Graham freeman 2005-07-15 00:24:12 UTC
I have installed XFree86 to try to replicate the success I had under the old
RedHat system, and the latest version exhibits the same problem as xorg.

I have experimented with various possibilities and have come up with a setting
which solves the problem.  Hand editing the XF86Config file so that it has the
following lines gives the desired higher resolution output. 

Section "Device"
	Identifier  "Card0"
#	Driver      "ati"
	Driver      "radeon"
	Option      "MonitorLayout"  "LVDS, SVGA"
	VendorName  "ATI Technologies Inc"
	BoardName   "Radeon RV200 LX [Mobility FireGL 7800 M7]"
	BusID       "PCI:1:0:0"
EndSection

I have not reverted to xorg to verify that the same solution will work there, as
I now have a production system that I can use tomorrow when I need it.

Comment 2 Walter Justen 2005-08-26 10:07:47 UTC
Thanks for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.

*** This bug has been marked as a duplicate of 162733 ***


Note You need to log in before you can comment on or make changes to this bug.