Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163308 - 2.6.12-1.1371_FC3smp fails booting
Summary: 2.6.12-1.1371_FC3smp fails booting
Keywords:
Status: CLOSED DUPLICATE of bug 163407
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-14 22:59 UTC by jedynamic
Modified: 2015-01-04 22:20 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-28 18:59:50 UTC


Attachments (Terms of Use)
This is a kernel serial boot log (deleted)
2005-07-14 23:01 UTC, jedynamic
no flags Details

Description jedynamic 2005-07-14 22:59:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
This kernel will not boot on my machine.
 


Version-Release number of selected component (if applicable):
2.6.12-1.1371_FC3smp

How reproducible:
Always

Steps to Reproduce:
1.Boot kernel
2.
3.
  

Additional info:

These boot messages appear to be relevant:
SCSI subsystem initialized
ata_piix: Unknown symbol ata_scsi_ioctl
ata_piix: Unknown symbol ata_std_bios_param
ata_piix: Unknown symbol ata_tf_read

Machine boots fine with 2.6.11-1.27_FC3smp.

Comment 1 jedynamic 2005-07-14 23:01:34 UTC
Created attachment 116775 [details]
This is a kernel serial boot log

Comment 2 Dan Carpenter 2005-07-14 23:06:28 UTC
Does it boot Ok with the UP kernel?

Are you upgraded to the most recent version of mkinitrd?

I think I've seen a mkinitrd race condition bug reported recently but I can't
find it.

Comment 3 jedynamic 2005-07-14 23:44:49 UTC
(In reply to comment #2)
> Does it boot Ok with the UP kernel?
> 
> Are you upgraded to the most recent version of mkinitrd?
> 
> I think I've seen a mkinitrd race condition bug reported recently but I can't
> find it.
Yes, it boots fine with UP. 

Version of mkinitrd = 4.1.18

I booted the SMP version again, and I see a bunch of errors about sd_mod before
the ata_piix errors:
sd_mod: Unknown symbol scsi_device_get
sd_mod: Unknown symbol scsi_wait_req




Comment 4 Dave Jones 2005-07-15 04:14:41 UTC
what does your /etc/modprobe.conf look like ?


Comment 5 Dan Carpenter 2005-07-15 05:05:17 UTC
I found the bugs I was looking for:

Take a look at bug 160652 and bug 162770

There is a new mkinitrd available but it takes some grovelling around to get the
dependencies correct.  It's described in bugs what to do.


Comment 6 Dave Jones 2005-07-15 17:52:11 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 7 Steve Malenfant 2005-07-19 16:15:17 UTC
I got about the same problem on 2.6.12-1.1372_FC3smp, but not on 2.6.12-
1.1372_FC3 (non-smp).
 
My error is : insmod: error inserting '/lib/ata_piix.ko': -1 Unknow symbol in 
module

Machine : Dell GX280N 3.0Ghz

Comment 8 jedynamic 2005-07-20 01:42:27 UTC
(In reply to comment #5)
> I found the bugs I was looking for:
> 
> Take a look at bug 160652 and bug 162770
> 
> There is a new mkinitrd available but it takes some grovelling around to get the
> dependencies correct.  It's described in bugs what to do.
> 
I updated my mkinitrd and initscripts (plus dependendices) to the FC4 versions
and I found that the problem still existed.  I finally fixed it by rebuilding
the kernel from the 2.6.12-1.1371_FC3smp src rpm (with the updated mkinitrd). 

I would try the new 1372 kernel but the machine is currently unusable (lightning
storm hit it).



Comment 9 Dan Carpenter 2005-07-20 04:20:12 UTC
You probably already know this (and if you don't it's too late anyway).

But you'll need to recreate the initrd after you install the mkinitrd package.

cd /boot/
mv initrd-2.6.12-1.1371_FC3.img initrd-2.6.12-1.1371_FC3.img.OLD
mkinitrd /boot/initrd-2.6.12-1.1371_FC3.img 2.6.12-1.1371_FC3

Sorry about the lightning storm...  

Comment 10 Tom Shield 2005-07-20 14:45:04 UTC
I have the same problem with 2.6.12-1.1372_FC3smp, and no problems with
2.6.12-1.1372_FC3 (UP) version.

error is

insmod: error inserting `/lib/ata_piix.ko': -1 unknown symbol in module

Running the UP version here are my modules that are loaded:

star% /sbin/lsmod
Module                  Size  Used by
nfs                   215721  2
lockd                  63849  2 nfs
parport_pc             28293  1
lp                     12873  0
parport                40073  2 parport_pc,lp
autofs4                28229  6
sunrpc                164229  3 nfs,lockd
microcode               7009  0
dm_mod                 57333  0
video                  15685  0
button                  6609  0
battery                 9285  0
ac                      4805  0
uhci_hcd               35025  0
ehci_hcd               40013  0
i2c_i801                8653  0
i2c_core               21313  1 i2c_i801
snd_intel8x0           34177  1
snd_ac97_codec         74937  1 snd_intel8x0
snd_pcm_oss            50673  1
snd_mixer_oss          17729  1 snd_pcm_oss
snd_pcm                98889  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              32837  1 snd_pcm
snd                    57285  6
snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              10785  2 snd
snd_page_alloc          9669  2 snd_intel8x0,snd_pcm
e1000                 102829  0
floppy                 64629  0
ext3                  130633  2
jbd                    83161  1 ext3
ata_piix                9413  0
libata                 46917  1 ata_piix
3w_xxxx                30305  3
sd_mod                 20289  4
scsi_mod              146313  3 libata,3w_xxxx,sd_mod


Comment 11 tibyke 2005-07-25 21:08:25 UTC
im experiencing the exact same problem with a hp/compaq ml320 server and 

01:02.0 SCSI storage controller: Adaptec AHA-3960D / AIC-7899A U160/m (rev 01)
01:02.1 SCSI storage controller: Adaptec AHA-3960D / AIC-7899A U160/m (rev 01)

2.6.12 1372 FC3 smp gives me a nice lil kernel panic, yet 2.6.11 latest version
FC3 SMP works just fine. everything is up-to-date.

regards,
tibyke

Comment 12 Dave Jones 2005-07-28 18:59:50 UTC

*** This bug has been marked as a duplicate of 163407 ***


Note You need to log in before you can comment on or make changes to this bug.