Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163305 - Save causes traceback
Summary: Save causes traceback
Keywords:
Status: CLOSED DUPLICATE of bug 163304
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-bind
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-14 22:09 UTC by Gabriel Schulhof
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-14 22:11:31 UTC


Attachments (Terms of Use)

Description Gabriel Schulhof 2005-07-14 22:09:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.7.8-2

Description of problem:
system-config-bind is pretty much useless, since one cannot save all the neat things one does with it. Upon save, an "Are you sure" type message box pops up, where, when you answer "Yes", the program produces the following in the terminal:

Traceback (most recent call last):
  File "/usr/share/system-config-bind/ErrorDialog.py", line 95, in on_exit
    self.callback(response,self.parms)
  File "/usr/share/system-config-bind/ZoneTree.py", line 463, in answer
    if s.bind.save() and s.bind.named_is_running():
  File "/usr/share/system-config-bind/BIND.py", line 239, in save
    s.zones[z]['zone'].save()
  File "/usr/share/system-config-bind/Zone.py", line 296, in save
    os.write(fd, self.out())
  File "/usr/share/system-config-bind/Zone.py", line 271, in out
    while ( begin <= end ) and (self.contents[begin] != '\n'):
IndexError: string index out of range

The Yes/No dialog remains on the screen.

Version-Release number of selected component (if applicable):
system-config-bind-4.0.0-16_FC4

How reproducible:
Always

Steps to Reproduce:
1. Install system-config-bind
2. Set up your domain
3. Attempt to save your changes.
  

Actual Results:  Python produced a trace in the terminal and did not save my changes.

Expected Results:  My changes should have been saved.

Additional info:

Comment 1 Gabriel Schulhof 2005-07-14 22:11:31 UTC

*** This bug has been marked as a duplicate of 163304 ***


Note You need to log in before you can comment on or make changes to this bug.