Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163304 - Save causes traceback
Summary: Save causes traceback
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-bind
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
: 163305 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-14 22:07 UTC by Gabriel Schulhof
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 4.0.0-19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-19 13:08:17 UTC


Attachments (Terms of Use)
Requested config tar (deleted)
2005-07-15 05:17 UTC, Gabriel Schulhof
no flags Details

Description Gabriel Schulhof 2005-07-14 22:07:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.7.8-2

Description of problem:
system-config-bind is pretty much useless, since one cannot save all the neat things one does with it. Upon save, an "Are you sure" type message box pops up, where, when you answer "Yes", the program produces the following in the terminal:

Traceback (most recent call last):
  File "/usr/share/system-config-bind/ErrorDialog.py", line 95, in on_exit
    self.callback(response,self.parms)
  File "/usr/share/system-config-bind/ZoneTree.py", line 463, in answer
    if s.bind.save() and s.bind.named_is_running():
  File "/usr/share/system-config-bind/BIND.py", line 239, in save
    s.zones[z]['zone'].save()
  File "/usr/share/system-config-bind/Zone.py", line 296, in save
    os.write(fd, self.out())
  File "/usr/share/system-config-bind/Zone.py", line 271, in out
    while ( begin <= end ) and (self.contents[begin] != '\n'):
IndexError: string index out of range

The Yes/No dialog remains on the screen.

Version-Release number of selected component (if applicable):
system-config-bind-4.0.0-16_FC4

How reproducible:
Always

Steps to Reproduce:
1. Install system-config-bind
2. Set up your domain
3. Attempt to save your changes.
  

Actual Results:  Python produced a trace in the terminal and did not save my changes.

Expected Results:  My changes should have been saved.

Additional info:

Comment 1 Gabriel Schulhof 2005-07-14 22:11:33 UTC
*** Bug 163305 has been marked as a duplicate of this bug. ***

Comment 2 Gabriel Schulhof 2005-07-14 22:12:35 UTC
Note to self: Never click "Refresh" on post_bug.cgi. Sorry !

Comment 3 Jason Vas Dias 2005-07-14 23:00:41 UTC
Please can you tell me what changes you made when this occurred ?
I've not been able to make s-c-b do this so far.
It would also be most helpful if you would send me your configuration files - do:
# . /etc/sysconfig/named; \
  tar -cpf /tmp/named.conf.tar ${ROOTDIR}/{etc/{named.conf,rndc*},var/named} 
and append /tmp/named.conf.tar to this bug or send it to jvdias@redhat.com .
Thank you!

Comment 4 Gabriel Schulhof 2005-07-15 05:16:27 UTC
The configuration is unchanged from a fresh rpm install, since I was unable to
commit any changes made in s-c-b. Here's what I tried:
Make a new master zone
- Add an MX
- Add a few A records

Comment 5 Gabriel Schulhof 2005-07-15 05:17:32 UTC
Created attachment 116791 [details]
Requested config tar

Comment 6 Gabriel Schulhof 2005-07-15 06:07:38 UTC
I was able to use the tool, but only in a really paranoid fashion. I basically
added one record (including the zone itself) and saved. I did not remove a
single time.

Comment 7 Jason Vas Dias 2005-07-16 00:48:52 UTC
This bug is now fixed with system-config-bind-4.0.0-18, soon to be in FC updates,
but which meanwhile can be downloaded from: 
http://people.redhat.com/~jvdias/system-config-bind
Please try out this version and let me know of any issues - thanks.

Comment 8 Gabriel Schulhof 2005-07-17 04:02:51 UTC
Yes. Now, when I click "New" on the toolbar while my zone is hilighted, instead
of a popup with all the different kinds of records I can add, I get:

Traceback (most recent call last):
  File "/usr/share/system-config-bind/ZoneTree.py", line 695, in NewClicked
    s.addMenu = AddMenu(s, sel, s.tree)
  File "/usr/share/system-config-bind/ZoneTree.py", line 252, in __init__
    if not s.zone.type in rr.types:
AttributeError: class NULL has no attribute 'types'


Comment 9 Jason Vas Dias 2005-07-17 22:11:32 UTC
This bug is now fixed with system-config-bind-4.0.0-19, soon to be in FC updates,
but which meanwhile can be downloaded from: 
http://people.redhat.com/~jvdias/system-config-bind
Please try out this version and let me know of any issues - thanks.

Comment 10 Walter Justen 2005-08-19 13:08:17 UTC
Thanks for the bug report. This particular bug was fixed and a update package
was published for download. Please feel free to report any further bugs you find.


Note You need to log in before you can comment on or make changes to this bug.