Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163297 - Minimal install: Text mode chooses different pakages then graphical mode
Summary: Minimal install: Text mode chooses different pakages then graphical mode
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-14 21:33 UTC by Ian Neubert
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-26 18:22:47 UTC


Attachments (Terms of Use)
anaconda-ks file from Graphical install (deleted)
2005-07-15 16:58 UTC, Ian Neubert
no flags Details
anaconda-ks file from text install (deleted)
2005-07-15 18:18 UTC, Ian Neubert
no flags Details

Description Ian Neubert 2005-07-14 21:33:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050516 Firefox/1.0.4

Description of problem:
The text mode installer is installing more packages than the graphical installer  when trying to make a minimal install. Either the text mode should assume you want minimal install after unselecting all the packages, or it should have a Minimal install checkbox like the graphical installer.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install in graphical mode and choose "Minimal" install, results in roughly 650 megs worth of packages. All on disc 1.
2. Install in text mode and unselect all packages (since there is no "Minimal" option) and you get roughly 720 megs of packages. And you need to use Disc 4.
  

Additional info:

Comment 1 Jeremy Katz 2005-07-15 11:39:14 UTC
What language did you install in?

Comment 2 Ian Neubert 2005-07-15 16:58:52 UTC
Created attachment 116809 [details]
anaconda-ks file from Graphical install

Comment 3 Ian Neubert 2005-07-15 16:59:27 UTC
In both cases I used "English (English)".

Comment 4 Ian Neubert 2005-07-15 18:18:22 UTC
Created attachment 116815 [details]
anaconda-ks file from text install

The text based installer selects a few different packages than the graphical
installer. In the %packages section of anaconda-ks here is what text does
differently than graphics mode.

It adds:
@ dialup
@ java
kernel-devel

And removes:
@ language-support

Comment 5 David Cantrell 2006-01-26 18:22:47 UTC
I don't know if this bug is still relevant.  We're now using yum as the backend
for package installation in anaconda.  In the text and graphical installation
modes, users are no longer given the option of Minimal, Desktop, Everything, or
whatever installs.  There is a default package set selected and as users enable
other groups, yum figures out what else is needed.

That said, I did two default installs from rawhide.  One using the graphical
interface and one using the text interface.  The anaconda-ks.cfg and install.log
files created by accepting the defaults in the installer are the same.  I
compared the output of 'rpm -qa' from both install runs and they are identical.


Note You need to log in before you can comment on or make changes to this bug.