Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163279 - console hangs when the user makes a "mistake"
Summary: console hangs when the user makes a "mistake"
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: mingetty
Version: 4
Hardware: powerpc
OS: Linux
medium
high
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-14 18:59 UTC by Luis
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-05-10 13:52:12 UTC


Attachments (Terms of Use)

Description Luis 2005-07-14 18:59:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
I installed Fedora Core 4 on a imac G5 ppc64
I made a minimal instalation a boot on textual mode.
If I login on any console Alt+F1 Alt+F6 every time I try to use command completion  
with a command/file it does not exists, the system completely hangs. Also if y push the up arrow key in order to see previous commands and i reach the top in the history.
I thought it was a bash issue but it also happens with cshell

Version-Release number of selected component (if applicable):
mingetty-1.07-5

How reproducible:
Always

Steps to Reproduce:
1.login on a terminal
2.use completion over a command/file that does not exists
3.
  

Additional info:

Comment 1 Colin Charles 2005-08-04 12:51:19 UTC
When it hangs, do you notice any messages (upon rebooting) around the system logs?

Also, if you were in X, and did this under xterm or gnome-terminal, is the
behaviour the same?

Comment 2 Luis 2005-08-09 10:15:55 UTC
It seems that this is the problem, from an email in the Fedora-ppc list
(original message from Dominik Epple <epple@tphys.physik.uni-tuebingen.de>)

Hi,

since I found some questions about this with google, but no answers,
this might be valuable to someone...

This is about running Fedora Core 4 on the current Apple iMac G5.

There are reports of gdm freezing the machine. I experienced this also,
and furthermore random crashes while using the console only.

It turned out this was because of the bell of the shell... every attempt
to play sound made the machine crash. Disabling sound completely by not
loading the sound driver modules solves this. On fedora you can do so by
adding them to /etc/hotplug/blacklist.

Have fun, Dominik.

Comment 3 Florian La Roche 2006-04-23 17:06:46 UTC
Is this item now resolved?

regards,

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.