Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163270 - Unresolved reference to vorbis_synthesis_halfrate
Summary: Unresolved reference to vorbis_synthesis_halfrate
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: openal
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phillip Compton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-14 17:43 UTC by Kenneth Porter
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-14 21:21:33 UTC


Attachments (Terms of Use)

Description Kenneth Porter 2005-07-14 17:43:55 UTC
After installing the symlink mentioned in bug 163268, I try to load
/usr/lib/libopenal.so and I get:

/usr/lib/libvorbisfile.so.3: undefined symbol: vorbis_synthesis_halfrate

Comment 1 Michael Schwendt 2005-07-14 19:54:18 UTC
How do you "try to load" it? What do you get for "rpm -qf
/usr/lib/libvorbisfile.so.3 ; rpm -V libvorbis ; objdump -T
/usr/lib/libvorbisfile.so.3 | grep half"?


Comment 2 Kenneth Porter 2005-07-14 21:21:33 UTC
PEBCAK

I had a local libvorbis.so.0 in the working directory and had used
"LD_LIBRARY_PATH=.". 

I'm still puzzled by the error message from dlerror(), though, as the file it
mentions does have the desired symbol. Once I hide the local vorbis library,
openal loads properly.


Note You need to log in before you can comment on or make changes to this bug.