Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163268 - No libopenal.so symlink
Summary: No libopenal.so symlink
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: openal
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phillip Compton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-14 17:38 UTC by Kenneth Porter
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-14 21:32:23 UTC


Attachments (Terms of Use)

Description Kenneth Porter 2005-07-14 17:38:45 UTC
I'm trying to bring up a game based on the Garage Games Torque Game Engine
(TGE). (http://www.garagegames.com/) It attempts to dlopen /usr/lib/libopenal.so
which is not present in openal-0.0-0.4.20040726. Adding the symlink allows it to
get further.

Comment 1 Michael Schwendt 2005-07-14 19:50:08 UTC
Not a bug. The symlink is in the openal-devel package where it belongs. The game
must not dlopen it, but libopenal.so.0 instead.

Comment 2 Kenneth Porter 2005-07-14 20:37:59 UTC
Where can I found out more about the semantics of the version number encoded in
the filename? I was unaware of this rule and haven't come across it any
documentation.

Comment 3 Kenneth Porter 2005-07-14 21:32:23 UTC
Answering my own question, I found the required info in the GCC HOWTO Linking
section, which can be found here:

http://www.faqs.org/docs/Linux-HOWTO/GCC-HOWTO.html#AEN575


Note You need to log in before you can comment on or make changes to this bug.