Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163266 - elfutils should be rebuilt for GLIBC_2.4 versioned symbols
Summary: elfutils should be rebuilt for GLIBC_2.4 versioned symbols
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: elfutils
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Roland McGrath
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-14 16:11 UTC by Robert Scheck
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 0.109-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-23 16:11:14 UTC


Attachments (Terms of Use)

Description Robert Scheck 2005-07-14 16:11:02 UTC
Description of problem:
elfutils should be rebuilt for GLIBC_2.4 versioned symbols to avoid possible 
problems with other programs, libraries etc.

Version-Release number of selected component (if applicable):
elfutils-0.108-5

How reproducible/Steps to Reproduce:
Okay, I've got some python CGIs doing something similar like rpm2html but using 
rpm-python (whether 4.4.1-22 or 4.4.2-0.8 is unimportant, both cause the same 
here). They produce the following error message: "ImportError: /lib/libc.so.6: 
version `GLIBC_2.4' not found (required by /usr/lib/librpmio-4.4.so)" - even 
until the output of "readelf -a /usr/lib/librpm-4.4.so | grep '2\.4'" is nothing 
(much thanks to jbj at this point).

Actual results:
I rebuilt elfutils-0.108-5 against latest glibc (2.3.90-2) and installed it. 
After that I had to restart httpd - now it works fine.

Expected results:
Rebuild of elfutils against latest Rawhide to avoid this and other (similar) 
"problems".

Additional info:
Sorry Jeff, I reverted my correct answer in IRC too fast, because I forgot 
restarting of httpd...shame on me :-(

Comment 1 Roland McGrath 2005-07-14 23:59:08 UTC
Versioning works.  This sounds like a bug somewhere else.
You need to include the actual recipe to reproduce the bug.

Comment 2 Robert Scheck 2005-07-23 16:10:23 UTC
At least, 0.109-2 works - closing now.


Note You need to log in before you can comment on or make changes to this bug.