Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163257 - rpmbuild doesn't complain when script file couldn't be opened
Summary: rpmbuild doesn't complain when script file couldn't be opened
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-14 15:19 UTC by Simon Perreault
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-14 17:30:22 UTC


Attachments (Terms of Use)

Description Simon Perreault 2005-07-14 15:19:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.1 (like Gecko)

Description of problem:
I'm using the -f and -p flags with the %post section of a spec file to have a 
fairly long Perl script be run after my RPM is installed. Initially I didn't 
know where the -f flag would be looking for my file. Should I put it in 
SOURCES, SPECS, or something else? Anyway, I figured that rpmbuild would 
complain until I got it right. 
 
Unfortunately, rpmbuild doesn't complain. Looking at the processScriptFiles() 
function, it looks like it should. However, something is making it not 
complain. It would be nice if it did complain and stop building my RPM. 

Version-Release number of selected component (if applicable):
rpm-4.4.1-21

How reproducible:
Always

Steps to Reproduce:
1. Use this %post section:  
  
%post -p /usr/bin/perl -f %{name}.post  
 
2. Make sure %{name}.post doesn't exist. 
3. Build RPM. 

Actual Results:  Built fine. 

Expected Results:  Rpmbuild should have aborted with an error message saying that it couldn't 
open %{name}.post. 

Additional info:

Comment 1 Simon Perreault 2005-07-14 17:30:22 UTC
It didn't complain because -f doesn't work when not using %setup, which will 
be filed as another bug. 


Note You need to log in before you can comment on or make changes to this bug.