Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163241 - Please implement versioned symbols in libnewt
Summary: Please implement versioned symbols in libnewt
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: newt
Version: 3
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Petr Rockai
QA Contact:
URL:
Whiteboard:
: 163240 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-14 13:03 UTC by Alastair McKinstry
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 0.52.1-0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-04 09:18:56 UTC


Attachments (Terms of Use)
Implement versioned symbols in libnewt library (deleted)
2005-07-14 13:05 UTC, Alastair McKinstry
no flags Details | Diff

Description Alastair McKinstry 2005-07-14 13:03:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050405 Firefox/1.0 (Ubuntu package 1.0.2)

Description of problem:
Please implement versioned symbols in the libnewt library.

We are using versioned symbols in the libnewt library in Debian (including current stable, v3.1).  Attached is the patch to apply to do this.

Use of versioned symbols solves a lot of dependency issues with libraries which depend on other libraries, (See Ulrich Dreppers 2004 paper on writing shared libraries for details), but it is important to use the same versioned symbols in each version to do so, so please use the attached versioning file.

Version-Release number of selected component (if applicable):
0.51.6

How reproducible:
Always

Steps to Reproduce:
See included patch.

Actual Results:  N/A

Expected Results:  N/A

Additional info:

diff -ruN newt-0.51.6-old/Makefile.in newt-0.51.6/Makefile.in
--- newt-0.51.6-old/Makefile.in 2004-07-06 10:42:06.000000000 +0100
+++ newt-0.51.6/Makefile.in     2004-07-06 11:53:57.000000000 +0100
@@ -5,6 +5,7 @@
 GPM_SUPPORT=@gpm_support@
 CFLAGS = $(RPM_OPT_FLAGS) -Wall  -D_GNU_SOURCE -g -O2 -DUTF8

+SHLIBFLAGS= -Wl,-O1 -Wl,--version-script,newt.0.51.ver
 VERSION = @VERSION@
 CVSTAG = r$(subst .,-,$(VERSION))
 SONAME = @SONAME@
@@ -110,7 +111,7 @@
 sharedlib: $(LIBNEWTSH)

 $(LIBNEWTSH): $(SHAREDDIR) $(SHAREDOBJS)
-       $(CC) -shared -o $(LIBNEWTSH) -Wl,-soname,$(LIBNEWTSONAME) $(SHAREDOBJS) $(SHLIBS)
+       $(CC) -shared -o $(LIBNEWTSH) $(SHLIBFLAGS) -Wl,-soname,$(LIBNEWTSONAME) $(SHAREDOBJS) $(SHLIBS)

 $(SHAREDDIR)/%.o : %.c
        $(CC) $(SHCFLAGS) -c $(CFLAGS) -o $@ $<
diff -ruN newt-0.51.6-old/newt.0.51.ver newt-0.51.6/newt.0.51.ver
--- newt-0.51.6-old/newt.0.51.ver       1970-01-01 01:00:00.000000000 +0100
+++ newt-0.51.6/newt.0.51.ver   2004-07-06 11:33:14.000000000 +0100
@@ -0,0 +1,5 @@
+NEWT_0.51 {
+       global: newt*;
+       local: *;
+};
+

Comment 1 Alastair McKinstry 2005-07-14 13:05:09 UTC
Created attachment 116744 [details]
Implement versioned symbols in libnewt library

Comment 2 Petr Rockai 2005-07-20 10:04:11 UTC
Shall go into next fedora release. 

Comment 3 Petr Rockai 2005-07-20 10:06:41 UTC
*** Bug 163240 has been marked as a duplicate of this bug. ***

Comment 4 Petr Rockai 2005-10-04 09:18:56 UTC
Fixed in FC-devel. Upstream tarball (0.52.2) will be released shortly. 


Note You need to log in before you can comment on or make changes to this bug.