Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163229 - Character set not specified in cvs commit email headers
Summary: Character set not specified in cvs commit email headers
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora Infrastructure
Classification: Retired
Component: cvs
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Jeremy Katz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-14 09:52 UTC by Paul Howarth
Modified: 2013-07-02 23:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-11-08 10:23:21 UTC


Attachments (Terms of Use)

Description Paul Howarth 2005-07-14 09:52:02 UTC
Description of problem:

The cvs system sends messages to the fedora-extras-commits list with unencoded
non-US-ASCII characters in the message headers. This typically happens when a
commit is made by a user with a non-US-ASCII character in their name, such as
José Pedro Oliveira or Ralf Corsepius. The commit message is generated with the
non-US-ASCII characters in the From: header, which is then changed to Old-From:
prior to distribution to the list.

RFC 2822 requires that message headers should be composed of characters 
in the US-ASCII character set, codes 0-127. RFC 2047 describes means of 
properly encoding non-US-ASCII characters in RFC 2822 messages.

The problem this is causing is that my mail server is running a milter that
looks for malformed headers (typically those of spammers trying to disguise
words like viagra by using accented characters for one or more vowels, but
failing to follow the RFC for how to encode these ;-)) and is rejecting emails
from the -commits list that are a result of commits by these few people. This
then results in me periodically receiving "list probe" messages as the mailing
list manager tries to determine if my address is working or not.

I suspect that the underlying cause of the problem is that the cvs 
system is not encoding the message headers for the character set it is 
using (UTF8?) when the commit messages are generated.

Comment 1 Elliot Lee 2005-12-20 21:28:52 UTC
Hey, see if Fedora Extras commit messages look better to you now...

Comment 2 Dennis Gilmore 2005-12-21 14:21:31 UTC
i got a probe message today  

Comment 3 Paul Howarth 2005-12-22 11:38:33 UTC
(In reply to comment #1)
> Hey, see if Fedora Extras commit messages look better to you now...

No discernable difference (had to wait a while for Ralf to make a commit ;-))

Old-From: "Ralf Corsépius" <corsepiu@fedora.redhat.com>
Date: Thu, 22 Dec 2005 06:36:34 -0500
From: "Ralf Corsépius" (corsepiu) <fedora-extras-commits@redhat.com>

RFC 2047 encoding missing from both of those "From" headers.


Comment 4 Ville Skyttä 2005-12-22 15:29:57 UTC
Encoding seems to be still missing indeed, but something has changed and the
messages now look okay in Evolution.

Comment 5 Ralf Corsepius 2005-12-22 16:13:06 UTC
(In reply to comment #4)
> Encoding seems to be still missing indeed, but something has changed and the
> messages now look okay in Evolution.
They now seem to be sending raw utf-8, instead of 7bit ASCII as they seem to
have done before. In my understanding this violates RFC 822.

They should be sending encoded 7bit strings instead (c.f. RFC 2047), i.e.
something like: 
From: Ralf =?ISO-8859-1?Q?Cors=E9pius?= <real email address>

Comment 6 Dennis Gilmore 2006-01-11 15:52:36 UTC
happened again this morning. 

Comment 7 Ralf Corsepius 2006-01-11 15:56:17 UTC
(In reply to comment #6)
> happened again this morning. 
See comment #5 - RH is sending broken, non-RFC compliant mail headers.


Comment 8 Dennis Gilmore 2006-01-11 16:10:42 UTC
yes i know that comment #1  asked if it was better  i was simply stating it 
was still no better 
 
top of my email was this    
INVALID HEADER (INVALID CHARACTERS OR SPACE GAP)    
    
Non-encoded 8-bit data (char C3 hex) in message header 'Old-From': Old-From:    
"Ralf Cors\303\251pius" <corsepi...    
Non-encoded 8-bit data (char C3 hex) in message header 'From': From: "Ralf    
Cors\303\251pius" (corsepi...    
    
i only started getting the probes  when is witched from a FC3 to FC4 server.    
i upgraded my amavis-new at that time.     
   
kmail  does show the corect data    
   
From: "Ralf Corsépius" (corsepiu) <fedora-extras-commits@redhat.com>   
thats inside the headers from the bounce mail my mail server sent back      
   
is perl being used to create the commits mail?  if so   
http://perldoc.perl.org/Encode/MIME/Header.html  looks like it would solve the  
issues pretty quickly  
  

Comment 9 Dennis Gilmore 2006-06-29 03:14:05 UTC
Elliot,  what can i do to fix  this ?   is the code for sending emails out in 
cvs somewhere?

Comment 10 Paul Howarth 2006-11-08 10:23:21 UTC
This has been fixed since mid-October (ticket 2006052310000016 on
https://admin.fedoraproject.org/tickets/).


Note You need to log in before you can comment on or make changes to this bug.