Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163228 - libc.info about threads are too misleading
Summary: libc.info about threads are too misleading
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: glibc
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-14 09:19 UTC by Suzuki Takashi
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-25 20:04:02 UTC


Attachments (Terms of Use)

Description Suzuki Takashi 2005-07-14 09:19:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; ja-JP; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Info document in glibc (libc.info) describes LinuxThreads.
But when running or compiling a program, NPTL is used instead by default.
There are perhaps some inappropriate explanations against NPTL.
That's too misleading for general users.

A few things I noticed were:
. Cancellation points are too limited and eg. select is not a cancellation point.
  (on NPTL, cancellation points are conformed to POSIX standard and
  almost all syscalls are cancellation points).
. pthread_cond_timedwait may return EINTR
  (one in LinuxThread also didn't return EINTR since glibc-2.1.3 though).


Version-Release number of selected component (if applicable):
glibc-2.3.4-2.9

How reproducible:
Always

Steps to Reproduce:
1. Invoke info libc.
2. Search Cancellation or pthread_cond_timedwait.


Additional info:

Comment 1 Jakub Jelinek 2005-07-14 09:27:38 UTC
For NPTL, the documentation is at
http://www.opengroup.org/onlinepubs/009695399/nfindex.html
or in the 3p section of manual pages.
info libc thread section simply documents LinuxThreads, so you shouldn't
be using it when writing NPTL (or portable POSIX threads) programs.

Comment 2 Suzuki Takashi 2005-07-14 10:13:33 UTC
I understand what you are saying.
But is there any documentation a general user can see at a glance
that he or she should't consult info.libc about threads?

Comment 3 Ulrich Drepper 2005-07-25 20:04:02 UTC
Use the POSIX man pages we ship (as Jakub pointed out) or buy a book on POSIX
threads.  Nobody has volunteered to write decent documentation for the upstream
glibc so there is nothing for us to import.

If you have a RHEL license and insist of RH providing such documentation then
talk to your Red Hat representative.


Note You need to log in before you can comment on or make changes to this bug.