Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163226 - xscreensaver cannot be rebuilt with perl installed
Summary: xscreensaver cannot be rebuilt with perl installed
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xscreensaver
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-14 08:31 UTC by Mamoru TASAKA
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-25 19:30:07 UTC


Attachments (Terms of Use)
xscreensaver build log (deleted)
2005-07-14 08:34 UTC, Mamoru TASAKA
no flags Details
Installation log file created during building binary (deleted)
2005-07-14 08:46 UTC, Mamoru TASAKA
no flags Details
Patch to send perl complaints to stderr (deleted)
2005-07-22 09:45 UTC, Mamoru TASAKA
no flags Details | Diff

Description Mamoru TASAKA 2005-07-14 08:31:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.7.8) Gecko/20050623 Fedora/1.0.4-5 Firefox/1.0.4

Description of problem:
xscreensaver source rpm cannot be rebuilt when perl package is installed.

Actually, at last building binary rpm complaints,
"File not found: /var/tmp/xscreensaver-root/usr/bin/perl".


Version-Release number of selected component (if applicable):
xscreensaver-4.21-4

How reproducible:
Always

Steps to Reproduce:
1. Make sure the perl package is installed.
2. Rebuild binary rpm from xscreensaver source
3.   

Actual Results:  At last it complains about missing perl file.

Expected Results:  Rebuilding binary rpm should success.

Additional info:

Removing "perl" entry from base,extras,gl-extras.files works for me.

Comment 1 Mamoru TASAKA 2005-07-14 08:35:00 UTC
Created attachment 116734 [details]
xscreensaver build log

Build log of xscreensaver.
It finally complaints about perl.

Comment 2 Mamoru TASAKA 2005-07-14 08:46:18 UTC
Created attachment 116736 [details]
Installation log file created during building binary

Installation log file named "base.files" created during building binary.

The missing ( unneeded ) file name /usr/bin/perl appears for some reason.
The same entry appears also in extras.files .

Comment 3 Ray Strode [halfline] 2005-07-14 14:31:24 UTC
Ah, so the function that generates the file lists is pulling in something from
the build output that it shouldn't be.

Comment 4 Mamoru TASAKA 2005-07-22 09:45:18 UTC
Created attachment 117048 [details]
Patch to send perl complaints to stderr

Sorry for replying you late.

Yes. I found that this is due to the behavior that 
(hacks,drivers)/Makefile generate the lists of the installed
files.
Patching the attached patch will solve the problem. Perl
complaints is sent to stderr and is not recoded into 
(driver,hacks).files.

Note: This problem is fixed in the xscreensaver
version 4.22 .

Comment 5 Ray Strode [halfline] 2005-07-22 14:39:37 UTC
Ah okay,

I'll just upgrade the xscreensaver in rawhide then.

Comment 6 Mamoru TASAKA 2005-08-06 07:12:52 UTC
Rebuilding xscreensaver 4.22-5 succeeded.
Thanks !!


Note You need to log in before you can comment on or make changes to this bug.