Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163225 - anaconda crashed while after partitioning with error "kernel was unable to read partition table"
Summary: anaconda crashed while after partitioning with error "kernel was unable to re...
Keywords:
Status: CLOSED DUPLICATE of bug 160693
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-14 08:15 UTC by alessandro brovelli
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-15 11:36:47 UTC


Attachments (Terms of Use)
error log (deleted)
2005-07-14 08:20 UTC, alessandro brovelli
no flags Details

Description alessandro brovelli 2005-07-14 08:15:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
After some file system problem I decided to upgrade from FC2 to FC4. I started a fresh installation, partitioned the HD, and while anaconda was gathering the informations required to start the installation, I got the error:
"error: Warning: The kernel was unable to re-read the partition table on /dev/hda (Device or resource busy).  This means Linux won't know anything nothing about
the modifications you made until you reboot.  You should reboot your computer before doing anything with /dev/hda." After this error I can dump a log file and the installation aborted.

If I start the installation using non-graphical mode, I got the same error, but I can ignore it; the processes finishes without trouble, but at the first boot the system is unable to start (kernel panic, try to use init=, etc.).

It's very annoying because I can install and run MS-Win instead...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.'Standard' installation
2. Maybe you should need and HD with some problems?
3.
  

Additional info:

Comment 1 alessandro brovelli 2005-07-14 08:20:24 UTC
Created attachment 116733 [details]
error log

Comment 2 Jeremy Katz 2005-07-15 11:36:47 UTC

*** This bug has been marked as a duplicate of 160693 ***


Note You need to log in before you can comment on or make changes to this bug.