Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163209 - FC3 obsoletes referenced for FC4 packages
Summary: FC3 obsoletes referenced for FC4 packages
Keywords:
Status: CLOSED DUPLICATE of bug 161071
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bret McMillan
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-14 02:31 UTC by Kam Leo
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-04-22 15:25:37 UTC


Attachments (Terms of Use)

Description Kam Leo 2005-07-14 02:31:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Clean install of FC4, not upgrade.  

Running "up2date --nox -u" produces the following error:

[snip]

Fetching rpm headers...
stat failed /var/spool/up2date/bind-9.3.1-6.FC4.i386.hdr
initRepo
bytes=440-38235
There was a fatal error communicating with the server. The message was:

An HTTP error occurred:
URL: http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/i386/bind-9.3.1-6.FC4.i386.rpm
Status Code: 404
Error Message: Not Found


After I upgrades packges using yum I performed another run of up2date and got the following:

[snip]

Fetching Obsoletes list for channel: dag...
initRepo

Fetching obsoletes list for http://apt.sw.be/fedora/3/en/i386/dag/...

Fetching Obsoletes list for channel: livna...
initRepo

Fetching obsoletes list for http://rpm.livna.org/fedora/3/i386/RPMS.lvn/...

Fetching Obsoletes list for channel: kde-redhat-stable-all...
initRepo

Fetching obsoletes list for http://apt.kde-redhat.org/apt/kde-redhat/all/stable...

Fetching Obsoletes list for channel: kde-redhat-stable...
initRepo

Fetching obsoletes list for http://apt.kde-redhat.org/apt/kde-redhat/fedora/4/i386/stable...

Fetching Obsoletes list for channel: jpackage16-generic...
initRepo

Fetching obsoletes list for http://mirrors.dotsrc.org/jpackage/1.6/generic/free/...

Fetching Obsoletes list for channel: extras...
initRepo

Fetching obsoletes list for http://download.fedora.redhat.com/pub/fedora/linux/extras/4/i386/...

Fetching Obsoletes list for channel: updates-mirrored...
initRepo

Fetching obsoletes list for ftp://mirrors.kernel.org/fedora/core/updates/3/i386/...

Fetching Obsoletes list for channel: updates-released...
initRepo

Fetching obsoletes list for http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/i386...

Fetching Obsoletes list for channel: base...
initRepo

Fetching obsoletes list for http://mirrors.kernel.org/fedora/core/3/i386/os/...

Fetching Obsoletes list for channel: jpackage16-fc4...
initRepo

Fetching obsoletes list for ftp://jpackage.hmdc.harvard.edu/JPackage/1.6/fedora-4/free/...

[/snip]


Why are FC3 files referenced for FC4?



Default up2date sources file was used, i.e.

$ cat /etc/sysconfig/rhn/sources
### This describes the various package repositories (repos) that up2date will
### query for packages. It currently supports apt-rpm, yum, and "dir" repos.

### Format is one repository (repo) entry per line, # starts comments, the
### first word on each line is the type of repo.

### The default RHN (using "default" as the url means use the one in the
### up2date config file).
#up2date default

### Note: when a channel label is required for the non up2date repos,
### the label is solely used as an internal identifier and is not
### based on the url or any other info from the repos.

### An apt style repo (the example is arjan's 2.6 kernel repo).
### The format is:
### type  channel-label      service:server         path        repo name
#apt arjan-2.6-kernel-i386 http://people.redhat.com ~arjanv/2.5/ kernel

### Note: for apt repos, there can be multiple repo names specified (space
### seperated).

### A yum style repo. The format is:
### type  channel-label     url

#yum my-favorite-rpms http://my.local.domain/fedora/linux/core/$ARCH/

### A local directory full of packages (a "dir" repo). For example:
#dir my-favorite-rpms /var/spool/RPMS/

### Repo Metadata
# Note that setting this makes up2date look in /etc/yum.repos.d/ for
# repository configuration.
# type channel-label url
repomd fedora http://fedora.redhat.com/

# Multiple versions of all repos except "up2date" can be used. Dependencies
# can be resolved "cross-repo" if need be.



Repo config files in /etc/yum.repos.d are as follows:

$ cat fedora-updates-mirror.repo
[updates-mirrored]
name=Fedora Core $releasever - $basearch - Released Updates Mirrored
baseurl=ftp://mirrors.kernel.org/fedora/core/updates/$releasever/$basearch/
        ftp://mirror.stanford.edu/pub/mirrors/fedora/linux/core/updates/$releasever/$basearch/
        ftp://limestone.uoregon.edu/fedora/updates/$releasever/$basearch/
        ftp://distro.ibiblio.org/pub/linux/distributions/fedora/linux/core/updates/$releasever/$basearch/
        ftp://mirror.colorado.edu/pub/fedora/linux/core/updates/$releasever/$basearch/
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/$releasever/$basearch/
mirrorlist=http://fedora.redhat.com/download/mirrors/updates-released-fc$releasever
enabled=1
gpgcheck=1

$ cat fedora-updates.repo
[updates-released]
name=Fedora Core $releasever - $basearch - Released Updates
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/updates/$releasever/$basearch
mirrorlist=http://fedora.redhat.com/download/mirrors/updates-released-fc$releasever
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora



Version-Release number of selected component (if applicable):
up2date-4.4.23-4

How reproducible:
Always

Steps to Reproduce:
1. Configure /etc/yum.repos.d with  .repo files listed above.
2. Run "sudo up2date --nox -u"
3.
  

Actual Results:  Obsoletes for FC3 are referenced for FC4 installation

Expected Results:  Only FC4 obsoletes should be checked

Additional info:

Comment 1 Paul Howarth 2005-07-19 07:05:22 UTC
This looks like a duplicate of #161071

Comment 2 John Thacker 2006-04-22 15:25:37 UTC

*** This bug has been marked as a duplicate of 161071 ***


Note You need to log in before you can comment on or make changes to this bug.