Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163181 - Update Disables Cron Jobs
Summary: Update Disables Cron Jobs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: vixie-cron
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-13 19:30 UTC by David Hart
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: pam-0.79-9.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-13 20:31:04 UTC


Attachments (Terms of Use)

Description David Hart 2005-07-13 19:30:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The following no longer run as scheduled since updating to vixie-cron-4.1-36.FC4.i386.rpm (July 12).

0,5,10,15,20,25,30,35,40,45,50,55 8-22 * * * /usr/sbin/fetchnews
20 5,17 * * * rsync -avrt rsync://mirrors.kernel.org/fedora/core/updates/4/i386 --exclude=debug/ --exclude=*i18* /var2/yum/Fedora/core/4/updates


Version-Release number of selected component (if applicable):
vixie-cron-4.1-36.FC4.i386.rpm 

How reproducible:
Always

Steps to Reproduce:
Not applicable. 

Actual Results:  No applicable

Expected Results:  Not applicable

Additional info:

Log prints:

Jul 13 15:25:01 dns crond[4055]: Cannot make/remove an entry for the specified session
Jul 13 15:25:01 dns crond(pam_unix)[4055]: session closed for user root

Comment 1 Jason Vas Dias 2005-07-13 19:45:05 UTC
Very strange! This does not happen on my system.

Were you upgrading from vixie-cron-4.1-33 ?

vixie-cron-4.1-36.FC4 adds support for the new pam audit system with this line
in /etc/pam.d/crond:
'
account required pam_loginuid.so
'
Does the problem persist if you comment out this line and restart cron ?

You should have upgraded PAM to 0.79-9.1 and audit to 0.9.15-1.FC4. 
Does the problem persist with these PAM and audit versions and with
the pam_loginuid line in /etc/pam.d/crond ?



Comment 2 David Hart 2005-07-13 20:13:45 UTC
I have pam-0.79-8. pam-0.79-9.1 only went to updates today - Jul 13 (vixie was
updated yesterday). 

The pam update seems to fix the problem.

Comment 3 Jason Vas Dias 2005-07-13 20:31:04 UTC
You should also ensure that you have audit*-0.9.15-1.FC4 .
Closing this bug as it is fixed with current audit & pam releases - thanks!


Note You need to log in before you can comment on or make changes to this bug.