Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163162 - Configurator wont load saved cfg files with certain settings
Summary: Configurator wont load saved cfg files with certain settings
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-kickstart
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 170445
TreeView+ depends on / blocked
 
Reported: 2005-07-13 16:26 UTC by Dan Roberts
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-28 18:50:37 UTC


Attachments (Terms of Use)

Description Dan Roberts 2005-07-13 16:26:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Description of problem:
Certain configuration settings in a kickstart .cfg file cause the configurator to break when loading the config file into the configurator for further editing.



Version-Release number of selected component (if applicable):
kickstart-2.3.22-3

How reproducible:
Always

Steps to Reproduce:
1. Run /usr/sbin/redhat-config-kickstart from a terminal
2. Fill in the root password fields and select "Probe for mouse" from the Mouse selection
3. Save the configuration as test.cfg
4. Open the saved configuration file

This also occurs if you select "Enable firewall" from the Firewall Configuration menu and checkmark "SSH" from the list of trusted services.

These settings in the GUI result in the following, apparently unhandled, lines in the .cfg file:

# System mouse
mouse
# Firewall configuration
firewall --enabled --ssh

Actual Results:  Resulting error message in the terminal from the mouse setting:

Traceback (most recent call last):
  File "/usr/share/redhat-config-kickstart/kickstartGui.py", line 272,
in on_activate_open
    self.fillData()
  File "/usr/share/redhat-config-kickstart/kickstartGui.py", line 303,
in fillData
    self.basic_class.fillData()
  File "/usr/share/redhat-config-kickstart/basic.py", line 312, in fillData
    mouseTag = mouseLine[0]
IndexError: list index out of range

In addition to the error message, the Ok and Cancel buttons in the file requestor window stop responding appropriately and it must be forced closed.


Additional info:

Comment 1 Chris Lumens 2005-09-08 20:38:59 UTC
This is a limitation of the kickstart parser in r-c-kickstart in that it does
not understand any options except the ones that it has boxes for in the GUI.  Of
course, it doesn't have a UI element for everything that anaconda understands so
lots of options are not supported.  The correct fix is to redo the kickstart
parser so that anaconda and r-c-kickstart share code, not duplicate parsers but
poorly.

Comment 6 Chris Lumens 2005-10-28 18:50:37 UTC
We are not going to be able to fix this in a RHEL3 update due to the amount of
work involved.  The correct fix I described above has been made in Rawhide which
will show up in FC5 and then later in RHEL5.  Unfortunately, RHEL3 r-c-kickstart
is simply not capable of understanding all the options that anaconda recognizes.


Note You need to log in before you can comment on or make changes to this bug.