Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163131 - code fails to compile when _IO_MTSAFE_IO is defined
Summary: code fails to compile when _IO_MTSAFE_IO is defined
Keywords:
Status: CLOSED DUPLICATE of bug 162634
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: 4
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-13 08:29 UTC by Balbir Singh
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-13 11:16:04 UTC


Attachments (Terms of Use)

Description Balbir Singh 2005-07-13 08:29:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050531 Firefox/1.0+

Description of problem:
The file lowlevellock.h is not distributed along with the binary rpm. The source rpm has this file. lowlevellock.h is included when _IO_MTSAFE_IO is defined.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Compile the lates Usagi (www.linux-ipv6.org) libraries with _IO_MTSAFE_IO enabled (which is the default)
2.
3.
  

Actual Results:  We get a failure "lowlevellock.h - No such file or directory"

Expected Results:  The file should have been found and included or if the file is internal to glibc, the standard headers should not include it

Additional info:

Comment 1 Jakub Jelinek 2005-07-13 11:16:04 UTC
Usagi is seriously buggy if it uses <bits/stdio-lock.h>.  That header is
certainly not intended for use by random programs/libraries, only included
to make prehistoric versions of GCC to compile.

*** This bug has been marked as a duplicate of 162634 ***


Note You need to log in before you can comment on or make changes to this bug.