Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163125 - attempt to share printer results in queueTree.py error
Summary: attempt to share printer results in queueTree.py error
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-13 05:12 UTC by Brian McMinn
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 0.6.137-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-25 09:45:01 UTC


Attachments (Terms of Use)

Description Brian McMinn 2005-07-13 05:12:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511

Description of problem:
system-config-printer does not allow me to mark a printer as shared.

I did a clean load of fc4.

My new hardware only supported USB printers so I connected my printer via a USB cable.

I added this printer via CUPS (accessed via http://localhost:631) and printed a test page.

I ran "system-config-printer" from the shell, selected the new printer (named "toy") and attempted to do Action->Sharing... to mark it as shared.  No sharing window came up and the following was printed to the shell:

bray 11 $ system-config-printer
Traceback (most recent call last):
  File "/usr/share/printconf/util/queueTree.py", line 683, in sharing_button_clicked
    queue_dict = self.name_dict[name]
KeyError: 'toy'

I was able to mark the printer as the default so part of the interface recognizes the printer.


Version-Release number of selected component (if applicable):
system-config-printer-0.6.131-1.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. oops - it's in the description
2.
3.
  

Expected Results:  I'm pretty sure I've done this before because this printer was shared before under fc1, fc2, and fc3.

Additional info:

Comment 1 Tim Waugh 2005-07-13 10:42:16 UTC
Thanks for the report.  The bug here is that you *could* click
Action->Sharing... -- for browsed queues, this should not be possible.  Queues
created by system-config-printer, and queues created by CUPS, can only be
modified by the tool that created them. (This is not exactly ideal.)

Comment 2 Tim Waugh 2005-07-13 10:46:21 UTC
Fixed in CVS.


Note You need to log in before you can comment on or make changes to this bug.