Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163123 - Problem with /etc/sysconfig/network-scripts/ifup-wireless (and others)
Summary: Problem with /etc/sysconfig/network-scripts/ifup-wireless (and others)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL: http://fedoraproject.org/wiki/DocsPro...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-13 03:55 UTC by J Dean Brock
Modified: 2014-03-17 02:54 UTC (History)
2 users (show)

Fixed In Version: 8.12-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-13 17:40:03 UTC


Attachments (Terms of Use)

Description J Dean Brock 2005-07-13 03:55:21 UTC
My /etc/sysconfig/networking/devices/ifcfg-wlan0 (as generated by the sysconfig
utilities) contains the line:
  RATE='54 Mb/s'

When I boot my system (before a fix), I got the message:
   Error: unrecognised wireless request "Mb/s"

In /etc/sysconfig/network-scripts/ifup-wireless, there is a line:
   iwconfig $DEVICE rate $RATE

If I change this line to
   iwconfig $DEVICE rate "$RATE"
I don't get the message when I boot

It could be that the problem is really in the config scripts that
write ifcfg-wlan0.  Maybe they should have put '54M' into
the file rather than '54 Mb/s'?

Version of release notes this bug refers to:

Fedora Core 4 final release

Comment 1 Karsten Wade 2005-07-13 05:26:52 UTC
Sorry, I don't see the relationship to the release notes.

rpm -qf /etc/sysconfig/network-scripts/ifup-wireless
initscripts-7.93.2-1

Reassigning to initscripts owner.

Comment 2 Bill Nottingham 2005-07-13 17:40:03 UTC
RATE enclosed in quotes in CVS, will be in 8.12-1 - thanks!


Note You need to log in before you can comment on or make changes to this bug.