Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163120 - socket(7) is wrong regarding RCVLOWAT
Summary: socket(7) is wrong regarding RCVLOWAT
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: man-pages
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-13 01:00 UTC by Andy Grover
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-09 09:42:29 UTC


Attachments (Terms of Use)

Description Andy Grover 2005-07-13 01:00:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
The man pages say that socket options SO_SNDLOWAT and SO_RCVLOWAT are not changeable in Linux and attempting to set them will return ENOPROTOOPT.

SNDLOWAT is not settable but RCVLOWAT is (I tried it), and the man page should reflect this.

Version-Release number of selected component (if applicable):
man-pages-1.67-7

How reproducible:
Always

Steps to Reproduce:
int i, j, lowat;
lowat = 1000;

i = socket(PF_INET, SOCK_STREAM, 0);

j = setsockopt(i, SOL_SOCKET, SO_RCVLOWAT, &lowat, sizeof(lowat));

if (!j)
  printf("the manpage is wrong\n");

Additional info:

Comment 3 Ivana Varekova 2005-09-12 09:13:53 UTC
Thank you for your notice. This man page is fixed in the last version of
man-pages (2.07-3).
The fixed version is:

  SO_RCVLOWAT and SO_SNDLOWAT
              Specify the minimum number of bytes in  the  buffer  until  the
              socket  layer  will pass the data to the protocol (SO_SNDLOWAT)
              or the user on receiving (SO_RCVLOWAT).  Their argument size is
              always  fixed  to  1  byte.   SO_SNDLOWAT  is not changeable in
              Linux.  SO_RCVLOWAT option is changeable only since Linux  2.4.
              getsockopt  is able to read them; setsockopt will always return
              ENOPROTOOPT.
 


Note You need to log in before you can comment on or make changes to this bug.