Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163113 - partitioning fails Attributeerror: 'NoneType' object has no attribute name
Summary: partitioning fails Attributeerror: 'NoneType' object has no attribute name
Status: CLOSED DUPLICATE of bug 161877
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: powerpc
OS: Linux
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
Depends On:
TreeView+ depends on / blocked
Reported: 2005-07-12 23:29 UTC by Evan Panagiotopoulos
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2005-07-26 04:00:38 UTC

Attachments (Terms of Use)

Description Evan Panagiotopoulos 2005-07-12 23:29:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511

Description of problem:
During installation of FC4 I receive an error on my iBook. I can't save the information without a floppy. Initially i received an error saying "pvcreate failed." Now I always get a multi-line exception that points to line 140, in get_partition_file_system_type 


(part.get_flag(parted.PARTITION_BOOT) == 1 and AttributeError: 'NoneType' object has no attribute 'name'

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot iBook with cd FC4 #1
2. Choose either text or graphical intallation
3. Any choice of installation and/partitioning

Actual Results:  A popup window lists the exception

Additional info:

Comment 1 Chris Lumens 2005-07-13 13:54:35 UTC
Please post the full traceback message you are getting.

Comment 2 Cedric Buot de l'Epine 2005-07-22 16:36:50 UTC
Same problem for me.
So here's the traceback.

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1160, in ?, dispatch)
  File "/usr/lib/anaconda/", line 496,
in run
  File "/usr/lib/anaconda/", line
174, in gotoNext
  File "/usr/lib/anaconda/", line
242, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/",
line 54, in partitionObjectsInitialize
  File "/usr/lib/anaconda/", line
108, in setFromDisk
    ptype = 
  File "/usr/lib/anaconda/", line
140, in get_partition_file_system_type
    elif (part.get_flag(parted.PARTITION_BOOT)
== 1 and
AttributeError: 'NoneType' object has no 
attribute 'name'

No idea of how to copy/paste, so I hope I didn't make too many typos.

My "parted /dev/hda print": 
Disk geometry for /dev/hda: 0.000-9590.273 megabytes
Disk label type: mac
Minor    Start       End     Filesystem  Name                  Flags
1          0.000      0.031              Apple                 
2          0.031      0.058              Macintosh             
3          0.059      0.085              Macintosh             
4          0.086      0.113              Macintosh             
5          0.113      0.140              Macintosh             
6          0.141      0.390              Macintosh             
7          0.391      0.640              Macintosh             
8          0.641      0.890              Patch Partition       
9          0.891      1.890              boot                  boot
10         1.891   4280.890              root                  root
11      4280.891   4792.890              swap                  swap
12      4924.047   9590.265  hfs+        Apple_HFS_Untitled_3  
Information: Don't forget to update /etc/fstab, if necessary.  

I tried to name the parts 9 and 10 from "unknown" to boot/root the the problem
seems to come from the swap.

Comment 3 Paul Nasrat 2005-07-22 16:44:37 UTC
What created the partition table above? This looks completely wrong. Please
delete the created partition and let anaconda partition in the free space.

Or else you'll need an Apple_Bootstrap partition with the boot flag (this is NOT
/boot it is something different). No other flags should be set on the linux
partitions unless it is lvm.

Comment 4 Jeremy Katz 2005-07-26 04:00:38 UTC

*** This bug has been marked as a duplicate of 161877 ***

Comment 5 Cedric Buot de l'Epine 2005-08-23 11:16:08 UTC
Anaconda did this before a first crash.
So I've "cat /dev/zero >> /dev/hda" and re-install macosx and all.
I then just had the same problem.
The first anaconda crash is reproductible when installing FC4 in french and text
re-wipe/re-re-installing the all stuff in english just worked fine.

Note You need to log in before you can comment on or make changes to this bug.