Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163079 - exception in team synchronizing perspective
Summary: exception in team synchronizing perspective
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Andrew Overholt
QA Contact:
URL:
Whiteboard:
: 174567 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-12 19:21 UTC by Colin Walters
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-03 16:56:15 UTC


Attachments (Terms of Use)
backtrace (deleted)
2005-07-12 19:21 UTC, Colin Walters
no flags Details

Description Colin Walters 2005-07-12 19:21:22 UTC
Description of problem:
I consistently get an exception in the Team Synchronizing perspective when doing
a synchronization.

Version-Release number of selected component (if applicable):
eclipse-jdt-3.1.0_fc-2

How reproducible:
Apparently always; I made a new workspace, did a cvs checkout of a project, then
tried to synchronize.

Comment 1 Colin Walters 2005-07-12 19:21:23 UTC
Created attachment 116676 [details]
backtrace

Comment 2 Andrew Overholt 2005-07-12 22:14:05 UTC
Well, it looks like this is probably a library bug since I removed
org.eclipse.team.core_3.1.0.jar.so (and verified that it wasn't compiled
on-the-fly in /tmp) and it still happened to me.  I will investigate further
tomorrow.

Comment 3 Ian Ridge 2005-10-10 09:24:24 UTC
Update on How reproducible:

The problem seems always repeatable with FC4-i386 distribution however I do NOT
see this problem when using FC4-x86_64 (64-bit AMD64).

On FC4-i386, I am seeing an exception and similar .log backtrace shown above,
whilst synchronizing.

Version:
Eclipse Platform Version: 3.1.0
Build id: I20050401-1645
Using Fedora 4, eclipse CDT, using a pserver cvs connection.


Comment 4 Andrew Overholt 2005-11-01 19:29:38 UTC
This bug is still happening with 3.1.1 :(  Is it a showstopper for anyone or can
I go ahead with the FC4 update?

Comment 5 Andrew Overholt 2005-11-01 19:49:22 UTC
I'm actually getting an additional line at the top of my stack trace:

org.eclipse.team.internal.ccvs.core.syncinfo.CVSResourceVariantTree.fetchMembers(org.eclipse.team.core.variants.IResourceVariant,
org.eclipse.team.core.runtime.IProgressMonitor)
(/usr/lib/gcj/eclipse/org.eclipse.team.cvs.core_3.1.1.jar.so)

Just so it's all here and easy to see, this is the relevant code (poor
formatting courtesy of bugzilla):

	/* (non-Javadoc)
	 * @see
org.eclipse.team.core.subscribers.RefreshOperation#getRemoteChildren(org.eclipse.team.core.subscribers.ISubscriberResource,
org.eclipse.core.runtime.IProgressMonitor)
	 */
	protected IResourceVariant[] fetchMembers(IResourceVariant remote,
IProgressMonitor progress) throws TeamException {
		ICVSRemoteResource[] children = remote != null ?
(ICVSRemoteResource[])((RemoteResource)remote).members(progress) : new
ICVSRemoteResource[0];
		IResourceVariant[] result = new IResourceVariant[children.length];
		for (int i = 0; i < children.length; i++) {
			result[i] = (IResourceVariant)children[i];
		}
		return result;
	}

Comment 6 Andrew Overholt 2005-11-02 18:35:13 UTC
(In reply to comment #2)
> Well, it looks like this is probably a library bug since I removed
> org.eclipse.team.core_3.1.0.jar.so (and verified that it wasn't compiled
> on-the-fly in /tmp) and it still happened to me.  I will investigate further
> tomorrow.

I don't know what I did back then, but it is definitely a mis-compilation
because I don't get it if I remove the corresponding .db (and rebuild-gcj-db).



Comment 7 Andrew Overholt 2005-11-03 16:56:15 UTC
This is fixed in rawhide.  Andrew Haley suggested that it was caused by gcc PR
23182.

gcc will probably be updated in FC4 at which point I will rebuild Eclipse with
it and push another update that will fix this issue.

Comment 8 Andrew Overholt 2005-11-30 14:34:19 UTC
*** Bug 174567 has been marked as a duplicate of this bug. ***

Comment 9 Ben Konrath 2006-01-04 19:41:52 UTC
Confirming this is fixed in updates-testing with the following package versions:

gcc-4.0.2-8.fc4
eclipse-platform-3.1.1-1jpp_1fc.FC4.11


Note You need to log in before you can comment on or make changes to this bug.